Jump to content

Bashbunny Internet doesn't like me


Mobie
 Share

Recommended Posts

I've tried and tried again.

 

I followed the Windows guide to connecting to the internet, shared my WiFi interface with Ethernet 2 (My Bashbunny)

 

The only step I didn't do was changing the IPV4 Address to 172.16.64.64 because when connecting it asks for the username (root) and then when I type hak5bunny it doesn't accept the password so no clue there.

 

Anyway, I can't ping anything, I can't connect to any repositories just gives me

0% Connecting to REPOSITORY HERE etc

 

So If there are any fixes please go ahead, I do have a Kali Linux virtual machine but It seems I can't SSH into it as it doesn't recognise the USB in Ethernet mode.

Link to comment
Share on other sites

Hi @Mobie,

I don't use windows at all, so I can only give you a hint according the linux machine:

  1. For internetsharing BB payload needs to be an ETHERNET payload
  2. Using a linux host means you have to use ATTACKMODE ECM_ETHERNET
  3. download the bb.sh script to your linux machine from bash bunny.com/bb.sh
  4. run bb.sh and use the configure option
  5. Connect the BashBunny, when the script asks for it
  6. ssh into the bashbunny and you are done!
Link to comment
Share on other sites

Hmm, wondering if VMware workstation doesn't have the feature to use USB devices within the vm. I'm using VMware Fusion and it can do it. Check your virtual machine settings. There should be a menu for USB & Bluetooth settings...

Other possibility: Use virtualbox. it can do it for sure...

Link to comment
Share on other sites

Hmm, I can do it within Fusion, but unfortunately only with one network adapter at the time active. Which means, that I can't do internet connection sharing... I will have a look into this, maybe I would need Fusion Pro, what would be a crap!

Nevertheless: You can do it for sure with virtualbox! Also check which ETHERNET mode you used (ECM or RNDS)! There should be an option to activate the new network connection at least! Maybe you can post a screenshot of your Desktop or the result of "ifconfig"?

Link to comment
Share on other sites

So, I now tested it again with virtualbox and Kali... It works fine!

  1. Use ATTACKMODE ECM_ETHERNET
  2. download bb.sh
  3. run bb.sh with Guided setup
  4. when asked to connect the BB ==> connect it physically and then go to virtualbox menu > Devices > USB and there should be a Linux Ethernet adapter available > choose it
  5. tell bb.sh to connect 
  6. ssh into the BB and you're online with the BB
Link to comment
Share on other sites

I'm not sure yet, but I assume that you need the Pro version of VMWare Workstation / Fusion to use more than one ethernet adapter simultaneously... what would be very sad, to be honest! I asked the VMware support, but probably an answer will take some time...

So get virtualbox! As I wrote: it worked fine in there!

Link to comment
Share on other sites

Uh, try to use the edit function to not flooding this thread... :wink:

And it would be helpful if you describe more in detail what you are doing in which vm software now... 

172.16.64.1 is the IP of the BB, so it doesn't make sense to define it as the default gateway! Also I told you to connect the BB not before the Guided Setup asks for it! If you would have done so, 172.16.64.1 wouldn't have been available... Do what I told you step by step, be calm and describe in detail what happens! Otherwise I can't help you... And please do me a favor: Do it in virtualbox as I don't have VMware workstation here, as I told you...

Link to comment
Share on other sites

This is what I did,

 

Ran the bb.sh setupu

G For guided setup

It asks for the default gateway, first time I set it as my systems default gateway

Used the eth0 interface

It asked for the bashbunny, connected it

Set bash bunny's interface to eth1

 

Tried to ssh into 172.16.64.1 did work, just a blank screen.

Link to comment
Share on other sites

Which vm system? VMware or virtualbox?
what's the default gateway IP?
What do you mean with "just a blank screen"? Do you have a ssh session or not?
So, if you have a ssh-session as it seems according you last post (again: use edit), try to ping 8.8.8.8 to see if there is at least a connection... 

But I'm quite sure you messed the guided setup, as your statement before doesn't match the others... Please answer the questions above, otherwise I have to give up and let somebody else try to explain...

Here is a picture from my bb.sh guided setup. Please note that my default gateway is for sure not the same as yours...

bb-sh Kopie.jpg

So finally I was too slow... lol... try to reproduce it, so that you understand how it works...

Edited by GermanNoob
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...