Jump to content

V4 firmware: Enabled modules never start on boot


Recommended Posts

Further to my post about Netcat reverse shell not starting, I've spent more time with the LanTurtle trying to get it working. I've noticed that whatever module I enable, it doesn't run at boot.  I've also noticed that with the Netcat module there have been times where I've started the module, only to find that when I return to the main netcat module screen, it's not running.  Unsure how I got it working.  It's very frustrating as I'm currently left with a LanTurtle that I have to SSH into whilst at the same device it's plugged into.  Not overly covert :)

Has anyone else had problems with enabled modules not starting?  Not necessarily with V4 firmware, any version will do

Thanks in advance

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...
  • 2 months later...

I've finally found some time to come back to the LanTurtle and see if I can get modules to autostart on boot.  

I've performed a manual factory reset of the LT with latest firmware (4), and decided to have another crack at the Netcat-revshell module, and I'm still not having this module start from boot.  

1. I've tested a manual start of this module and my NC listener works - I can interact with the LT machine from my remote box

2. I've set the Bootup status to ENABLED, and rebooted

3. After login to the LT again, I can see that the netcat-revshell module still has Bootup Status: ENABLED, and current status: STOPPED

4. I can manually start this module and it works like a charm.

5. I've looked at another module - URLSnarf.  that's not saving my configuration selection (save log to /tmp/) so here's another module that's not fully working.


This is just frustrating; @Sebkinne and @Darren Kitchen are there any plans to look into this issue? I'm not the only user with these problems.  Has Hak5 stopped supporting LT?  If so, please confirm and I'll ditch the LT altogether and not spend more time on it anymore.

I really want to use the LT on engagements, and to generally have a play around with some of the other modules that use tools/tech I've not spent much time with.  If the LT is flawed, then it's just an expensive usb-ethernet adapter.


hope that we see these issues resolved soon


Link to comment
Share on other sites

  • 1 month later...
On 7/27/2018 at 3:17 PM, victorgonal said:

Same issue here, tried with meterpreter and OpenVPN. Every time I plug it in I've to manually start the module.

Ok, I just reverted it all to factory, did a clean installation of meterpreter module and now it allows me to mark it as enabled at boot. All working fine.

Link to comment
Share on other sites

  • 4 years later...

If you have been having an issue with things not running on boot when enabled in the GUI, I have found that creating cron jobs in the terminal are effective. I was able to manually start the OpenVPN module, but it would not start automatically on reboot. When you start a service, the GUI usually tells you the PSID(Process ID). To view it in the terminal, just use the "ps" command. Then you can see the command used by the system to start the module.

For example:

The OpenVPN module process is shown as - /usr/bin/openvpn --daemon --configure /etc/openvpn/my-vpn.conf

Use nano to create and edit a file. - nano "myfile.sh"

The specific command in this example is openvpn --daemon --configure /etc/openvpn/my-vpn.conf which just takes away the path from the command.

Save the file with CTRL+O

Exit the file with CTRL+X

Make the file executable with chmod +x "myfile.sh"

Use crontab -e, which will put you into a text editor like vi.

Type "i" to enable insert mode.

Then specify the time you would like this command to run, followed by your shell script

@reboot /"path-to-your-file"/"myfile.sh"

To exit and save press ESC, then type :"wq", and then Enter

Going through this process might help you further understand how Linux works. Figuring this out was definitely a rewarding experience for me. This concept should also work with any other modules that you are able to manually start, but will not start automatically after a reboot.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...