Jump to content

apt-get update error, ping error


Recommended Posts

3 minutes ago, Harold Finch said:

or I configured wrong.

It looks like you have specified the bashbunny (172.16.64.1) as the default gateway, dont  think thats right. Try the IP of your router or USB 3G device.

Edited by Just_a_User
Link to post
Share on other sites
2 hours ago, Just_a_User said:

It looks like you have specified the bashbunny (172.16.64.1) as the default gateway, dont  think thats right. Try the IP of your router or USB 3G device.

ok,  I changed default gateway ip to my router default gateway.

and connected ... but when I try to login with default password, permission denied. 

 

Edited by Harold Finch
Link to post
Share on other sites
2 hours ago, Just_a_User said:

Did you change it to your routers IP or your routers default gateway IP? they are different.

when I change default ip adress to 172.16.64.1, connection is not establishing. AND... when I change default ip adress to my wifi router's ip adress, connection establishing (but, cant login  with default login and password hak5bunny).

Edited by Harold Finch
Link to post
Share on other sites

@Harold Finch, are you prompted with "bunny login:"? just to be sure, that you are trying to log in to the right device...

If you don't remember your credentials anymore, you can reset your bunny by doing the firmware reset as described here: https://wiki.bashbunny.com/#!./index.md#Firmware_Recovery

then you the default credentials are working again.

@Just_a_User: Respect for your patience!

  • Like 1
Link to post
Share on other sites
6 minutes ago, GermanNoob said:

@Just_a_User: Respect for your patience!

Thanks, i can only do soo much and im getting to my limit :)

I just set Internet connection sharing on ubuntu 17 to the bashbunny without using the script and it was pretty straight forward.  I think some fundamentals are missing and possibly some language differences that are making this harder than it should be. The device itself is fine.

 

  • Like 1
Link to post
Share on other sites
12 hours ago, Just_a_User said:

Thanks, i can only do soo much and im getting to my limit :)

I just set Internet connection sharing on ubuntu 17 to the bashbunny without using the script and it was pretty straight forward.  I think some fundamentals are missing and possibly some language differences that are making this harder than it should be. The device itself is fine.

 

Dear friend.  Can you send me ip configurations of bash bunny on ubuntu  (with screenshots) ?  Im so confused about configuration. 

Link to post
Share on other sites
4 hours ago, Harold Finch said:

Dear friend.  Can you send me ip configurations of bash bunny on ubuntu  (with screenshots) ?  Im so confused about configuration. 

OK last post :)

On a fresh install of Ubuntu 17. Bashbunny set up with a plain pauload in switch 1 or 2 with only ECM_ETHERNET. Plug it in and wait for Ethernet interface to come up on ubuntu.

Open network setting and change ipv4 settings to manual and enter ip as 172.16.64.64 with netmask of 255.255.255.0 like below

Selection_002.png.1222e9ffbb7a00ce94f3479479c5302a.png

Once done open up a terminal and enter in the command "nm-connection-editor" to open up a different connection editor, go to the ipv4 settings and change the drop down from manual to shared to other computers as shown in other picture below.

Selection_004.png.6d24d1858656c7eb3ca9771c5c04ef84.png

Save and exit. You may need to unplug/replug your bashbunny (tor turn the interface off/on) but you can then log into the bashbunny and it should also have  Internet. That works for me.
 

Edited by Just_a_User
Link to post
Share on other sites
55 minutes ago, Just_a_User said:

OK last post :)

On a fresh install of Ubuntu 17. Bashbunny set up with a plain pauload in switch 1 or 2 with only ECM_ETHERNET. Plug it in and wait for Ethernet interface to come up on ubuntu.

Open network setting and change ipv4 settings to manual and enter ip as 172.16.64.64 with netmask of 255.255.255.0 like below

Selection_002.png.1222e9ffbb7a00ce94f3479479c5302a.png

Once done open up a terminal and enter in the command "nm-connection-editor" to open up a different connection editor, go to the ipv4 settings and change the drop down from manual to shared to other computers as shown in other picture below.

Selection_004.png.6d24d1858656c7eb3ca9771c5c04ef84.png

Save and exit. You may need to unplug/replug your bashbunny (tor turn the interface off/on) but you can then log into the bashbunny and it should also have  Internet. That works for me.
 

So thanks... and please look at this video. This is my computer and connection bash bunny. 

 

Edited by Harold Finch
Link to post
Share on other sites
16 minutes ago, Harold Finch said:

So thanks... and please look at this video. This is my computer and connection bash bunny. 

lol you made me post again :P

I didn't use the script on Ubuntu 17.... ubuntu 17 does not have ifconfig installed and does not use the ethx and wlanx interface references. I can be done but to be honest im not going to explain to you how to do that. if you can't get adb installed onto your bashbunny with the information in this thread then give up :)

Edited by Just_a_User
Link to post
Share on other sites
47 minutes ago, Just_a_User said:

lol you made me post again :P

I didn't use the script on Ubuntu 17.... ubuntu 17 does not have ifconfig installed and does not use the ethx and wlanx interface references. I can be done but to be honest im not going to explain to you how to do that. if you can't get adb installed onto your bashbunny with the information in this thread then give up :)

THANK YOU VERY MUCH DEAR FRIEND.... I just add gateway ip adress "172.16.64.1" to bashbunny IPv4 settings.   I updated the system and installed android tools. 

Edited by Harold Finch
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...