Jump to content
Harold Finch

apt-get update error, ping error

Recommended Posts

Hi. I connected with Putty. OS is Debian. and I want to update it and I want to install android -tools-adb android-tools-fastboot. But I cant. Cause, happening some errors. I changed sources list. But same error. What's problem?

 

Edited by Harold Finch

Share this post


Link to post
Share on other sites

You need to share your Internet connection with your bunny.

From Bash Bunny Documentation https://www.hak5.org/gear/bash-bunny/docs

``Sharing an Internet connection from Windows.

  1. Configure a payload.txt for ATTACKMODE RNDIS_ETHERNET
  2. Boot Bash Bunny from RNDIS_ETHERNET configured payload on the host Windows PC
  3. Open Control Panel > Network Connections (Start > Run > “ncpa.cpl” > Enter)
  4. Identify Bash Bunny interface. Device name: “USB Ethernet/RNDIS Gadget”
  5. Right-click Internet interface (e.g. Wi-Fi) and click Properties.
  6. From the Sharing tab, check “Allow other network users to connect through this computer’s Internet connection”, select the Bash Bunny from the Home networking connection list (e.g. Ethernet 2) and click OK.
  7. Right-click Bash Bunny interface (e.g. Ethenet 2) and click Properties.
  8. Select TCP/IPv4 and click Properties.
  9. Set the IP address to 172.16.64.64. Leave Subnet mask as 255.255.255.0 and click OK on both properties windows. Internet Connection Sharing is complete

``

Edited by Jtyle6

Share this post


Link to post
Share on other sites

I did it (on switch 1 mode). And then, I plugged out it, swtiched mode to Armed Mode and plugged in for connecting with Putty. Connected and I logged in with default login and password. But, the same problem  continues... :/  I cant update OS.

 

Edited by Harold Finch

Share this post


Link to post
Share on other sites
1 minute ago, Just_a_User said:

Have you tried re-reading the documentation  https://www.hak5.org/gear/bash-bunny/docs  scroll down to Internet connection section, extend the part for your OS and follow instructions.

I did it (on switch 1 mode). And then, I plugged out it, swtiched mode to Armed Mode and plugged in for connecting with Putty. I connected and logged in with default login and password. But, the same problem continues...

Share this post


Link to post
Share on other sites
1 minute ago, Harold Finch said:

But, the same problem continues...

Are you sure you read and understood the instructions? :)

For debian it suggests using the bb.sh script. You haven't mentioned using that in your posts.

Share this post


Link to post
Share on other sites
2 minutes ago, Just_a_User said:

Are you sure you read and understood the instructions? :)

For debian it suggests using the bb.sh script. You haven't mentioned using that in your posts.

I cant download anything. there is an error happening

Share this post


Link to post
Share on other sites
7 minutes ago, Harold Finch said:

I cant download anything. there is an error happening

Why do you need to download the script to the bacshbunny?

Share this post


Link to post
Share on other sites
9 hours ago, Just_a_User said:

Why do you need to download the script to the bacshbunny?

for android hacking. I want to download android-adb-tools to bashbunny. But, I cant connect debian to  internet in putty.

Share this post


Link to post
Share on other sites
45 minutes ago, Harold Finch said:

for android hacking. I want to download android-adb-tools to bashbunny. But, I cant connect debian to  internet in putty.

:) I understand what you want to do once you have Internet access on the bashbunny. To do that you need to set up Internet connection sharing.

Let me break it down for you: -

1.Connect Debian PC to Internet using wifi or Ethernet.

2. Download the bb.sh script (on your Debian box) and run it following the on screen instructions

3. when instructed plug in the bashbunny, then click connect option

4. ssh t obunny and check it has internet access. then apt-get install adb etc...

Unless your using windows????

 

Edited by Just_a_User

Share this post


Link to post
Share on other sites
4 minutes ago, Just_a_User said:

:) I understand what you want to do once you have Internet access on the bashbunny. To do that you need to set up Internet connection sharing.

Let me break it down for you: -

1.Connect Debian PC to Internet using wifi or Ethernet.

2. Download the bb.sh script (on your Debian box) and run it following the on screen instructions

3. when instructed plug in the bashbunny, then click connect option

4. ssh t obunny and check it has internet access. then apt-get install adb etc...

Unless your using windows????

 

I'm using Windows, now. On arming mode, I can open debian (in putty). But, in this mode, I cant share internet to bashbunny.. For sharing the internet, I must to change mode to switch mode. Then I can configure and share internet vs bash bunny.... But  now I cant to connect bash bunny vs putty. Cause in this mode I cant see port number.

Can you do it vs team viewer on my computer?

Share this post


Link to post
Share on other sites
12 minutes ago, Harold Finch said:

Can you do it vs team viewer on my computer?

 i don't recommend doing that with people you dont know. :)

12 minutes ago, Harold Finch said:

I'm using Windows, now. On arming mode, I can open debian (in putty). But, in this mode, I cant share internet to bashbunny.. For sharing the internet, I must to change mode to switch mode. Then I can configure and share internet vs bash bunny.... But  now I cant to connect bash bunny vs putty. Cause in this mode I cant see port number.

Aare you saying when the bashbunny is in rndis ethernet mode your windows machine does not detec the bashbunny as a network interface?

If it detects the bashbunny as a network interface you need to setup internet connection shareing to it - following the (windows) instructions you have been given or the wiki.

If the device isnt not showing up in windows as a network adapter check your payload is using rndis ethernet mode, then see if there is an unknown device in device manager, if so delete it and try plugging it in again so windows correctly installs the driiver again.

 

Edited by Just_a_User

Share this post


Link to post
Share on other sites
On 2/4/2018 at 1:10 PM, Just_a_User said:

 i don't recommend doing that with people you dont know. :)

Aare you saying when the bashbunny is in rndis ethernet mode your windows machine does not detec the bashbunny as a network interface?

If it detects the bashbunny as a network interface you need to setup internet connection shareing to it - following the (windows) instructions you have been given or the wiki.

If the device isnt not showing up in windows as a network adapter check your payload is using rndis ethernet mode, then see if there is an unknown device in device manager, if so delete it and try plugging it in again so windows correctly installs the driiver again.

 

The bashbunny in switch mode 1...    Internet sharing is OK.  But, there is no any port for connect vs putty to bash bunny..

 

Edited by Harold Finch

Share this post


Link to post
Share on other sites

OK it seems your perhaps confused with serial and ssh access, both can be done with putty i believe. When in arming mode you usually use serial access to a com port - with ssh you set up a different session to the bashbunny using its ip address and port 22.

Share this post


Link to post
Share on other sites
On 2/4/2018 at 1:24 PM, Just_a_User said:

OK it seems your perhaps confused with serial and ssh access, both can be done with putty i believe. When in arming mode you usually use serial access to a com port - with ssh you set up a different session to the bashbunny using its ip address and port 22.

its switch mode 1.  (payload RNDIS)    172.16.64.10

 

Edited by Harold Finch

Share this post


Link to post
Share on other sites
13 minutes ago, Harold Finch said:

its switch mode 1.  (payload RNDIS)

Thats the IP given to your windows machine, not he bashbunny itself. The bashbuny is on 172.16.64.1

Edited by Just_a_User

Share this post


Link to post
Share on other sites
On 2/4/2018 at 1:54 PM, Just_a_User said:

Thats the IP givin to your windows machine, not he bashbunny itself. The bashbuny is on 172.16.42.1

Thank you very much. Its worked (ssh connection)... but, why internet connection is gone, i dont understant.

 

Edited by Harold Finch

Share this post


Link to post
Share on other sites

Your mobile broadband connection says not shared... maybe you need to set up internet connection sharing on your windows machine again? Windows is a PITA sometimes, use Linux ;)

Share this post


Link to post
Share on other sites

Pretty sure its a windows issue, its always causing shenanigans :) Maybe try disconnecting/reconnecting bashbunny, pray to the windows gods, check the weather, throw spices over your left shoulder & last resort, sacrifice a chicken!

Looks like the bunny itself is fine and working.

Share this post


Link to post
Share on other sites

Why connection is not established ? 

I configured default gateway ip adress to 172.16.64.1 . And shared internet connection from wlan0 to BashBunny at eth1 through default gateway 172.16.64.1

BUT connection is not established... 

 

Edited by Harold Finch

Share this post


Link to post
Share on other sites
48 minutes ago, Harold Finch said:

Why connection is not established ? 

did you run the script and hit hit "C" to connect?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...