Jump to content

Hanging at grabbing ID3


Kaffa
 Share

Recommended Posts

Found out about this program after searching for such a program, and instantly started working on it. Followed the noobs post, started it up and I ran into the problem of having the correct Flash. After tinkering for an hour, I decided to post here in the hopes that I'm just missing a simple detail.

First, the info:

Flash Switch Plugin

NoScript Plugin

Mozilla Firefox

Windows XP

Pandora's Jar 7.4.0

Flash 8.0 r24

Now the problem. I can start the program fine, connect to Pandora. Sometimes it won't be able to retrieve the artist/song bio, despite having a last.fm account. At the bottom of the screen where it shows what executable its performing, it shows grabMP3() and fetching ID3 info, but the CMD window shows:

***processing directory: hsperfdata_Jamie***

DEBUG [Thread-2] (Mp3Processor.java:154) - unable to parse file: C:DOCUME~1JamieLOCALS~1Temphsperfdata_Jamie2428 marking file as non-mp3

DEBUG [Thread-2] (Mp3Processor.java:119) - recent non mp3 file found: 2428 - will continue to next file

DEBUG [Thread-2] (Mp3Processor.java:129) - no more mp3 found in dir

DEBUG [Thread-2] (Mp3Processor.java:150) - file be289.tmp is not an mp3

DEBUG [Thread-2] (Mp3Processor.java:122) - no more mp3 found in dir

INFO [Thread-2] (Server.java:112) - unable to rip MP3

java.lang.RuntimeException: unable to find file make sure you have Pandora running in a FIRFOX browser

at util.Mp3Processor.findCurrentTmpMp3(Mp3Processor.java:59)

at util.Mp3Processor.findCurrentMP3(Mp3Processor.java:25)

at servlet.ProcessAction.handleMP3Request(ProcessAction.java:31)

at server.Server.handleHTTPRequest(Server.java:110)

at server.Server.run(Server.java:83)

INFO [Thread-2] (Server.java:42) - unable to rip MP3 unable to find file make sure you have Pandora running in a FIRFOX browser

java.lang.RuntimeException: unable to rip MP3 unable to find file make sure youhave Pandora running in a FIRFOX browser

And the Pandora's Jar window shows:

unable to retrieve top fans from last.fm: top friends not found

localhost connected to server.

unable to rip MP3 unable to find file make sure you have Pandora running in a FIRFOX browser

Pretty sure I got it running in a Firefox browser, and I've run out of ideas. Any thoughts?

Link to comment
Share on other sites

same here.

Config:

-Jar 7.4_Build4 (newest available i think)

-Firefox 2.0.0.1

-Flash 8

I see, that pandora's jar will write a plugtmp-1, plugtmp-2... in the folder: C:DOKUME~1profilenameLOKALE~1Temp - or in a subfolder plugtmp under the mentioned path.

then, pandora's jar renames the file to a numeric value (which is also listed in md5 file in root folder). but it won't move it finally to the mp3 folder with the error already shown by kaffa: unable to rip MP3 unable to find file make sure you have Pandora running in a FIRFOX browser

strange...

Link to comment
Share on other sites

@leeroy: I see you're working with a non-English version of Windows, but that can not be the problem...

first: Not Pandora's Jar is making those folders, pandora.com is. And as well the numeric named files are from pandora. You even have them there when you use Pandora without PJ.

next thing: Turn the last.fm stuff off, as it's completely buggy! Bio and stats don't work and timestamps are incorrect... For getting PJ to work, switch off all that unecessary stuff! (same for itunes thingy...) And maybe switch off CDDB lookup if you got it on.

Are you using the standard configuration file? If not, try it with the standart before you adapt it!

And have you tried clicking on the grab-button and seing if it works then?

Link to comment
Share on other sites

thx for help, zoltan

yes, i have a german version.

1: interesting. thx for explanation!

2: i never used that stuff - only cruise control is on, and pandorausername is entered.

3: yes, standard config file. always used that.

4: yep, i tried that and it didnt change anything (officially grabbing but never seen an mp3 in any folder)

what i found out now is, that version 7.4 (the older one, not the "7.9" alias 7.4_4) works again! in october or november it didn't, because pandora seems to have changed anything in their routine (if i remember correctly). but now, after i tried to work with "7.9", i just replaced the jar with the older one - and its working again, although without the new features.

Link to comment
Share on other sites

I tried using Flash v8.0, but Pandora insisted that i downloaded the most recent version.

Then i decided to follow your suggestion and read some other topics until i found a topic saying that there was this Javascript script for Greasemonkey that did the trick and allowed Pandora to play on Flash v8.0

Thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...