Jump to content
Hak5 Forums
darkone

module issues?

Recommended Posts

Hi everyone, 

 

ill start by saying i am no linux pro,  i have more then plenty to learn ;)

i recently got a new job who want to start a pentest lab lateron,  and for that i got this epic tool  the pineapple tetra (and more but today ill ask about tetra)

 

i managed to get a captive portal up and running, inject a payload with cursed screech,  AV removed the payload  but still  it did wat the tetra should have done.

 

now i updated the tetra totay to firmware 2.0.2

and for some reason i cant start SSL plit, (dependancy's installed,  gave tetra a factory reset, and tried again)

i am unable to install the dependancies of Ettercap

 

one of the things i found is taht the /dev/root  /rom? folder is full 12.50mb out of 12.50mb used? can that be one of my issues?

in the webinterface on the log i dont see anything that i can relate to these 2 issues, (last log entry is from an hour ago and i tried both options again 5 min ago)

 

any tips on how to find who and or what the problem is with these problems?

 

thanks in advance!

 

 

 

 

Share this post


Link to post
Share on other sites

WPS and Meterpreter also dont seem to work, 

 

with meterpreter i cant even put in a hostname or  put autostart on/off,

and WPS wont start.

 

Share this post


Link to post
Share on other sites

Your issues are strange.i also experience the ettercap dependencies issue  but i didn't really care because i thought i could always do it manually. 

Yes the root folder should be full. This is not the problem.

Share this post


Link to post
Share on other sites

Hi,

same here on TETRA 2.0.2. Most dependencies work. However, ettercap, ngrep and dump1090 do not install. I was trying to play a bit with the hackrf module, but the dependencies were not installes either. In all cases the systems tells me to install the progs, but then it shows up "Dependencies not installed".

Now, I had dump1090 uninstalled and installed again. Now it works.

Meterpreter Module shows as "not installed", but I have it in my "Modules list" ...

Share this post


Link to post
Share on other sites

Same issue over here. When I try to install ettercap manualy I receive the following error message:

opkg install ettercap
Installing ettercap (0.8.2-1) to root...
Downloading https://www.wifipineapple.com/nano/packages/ettercap_0.8.2-1_ar71xx.ipk.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for ettercap:
 *      libnet1 *
 * opkg_install_cmd: Cannot install package ettercap.
 

Something about a missing or wrong libnet1 module/library. 

Anyone any idea how to fix this?

Thanks in advance.

  • Like 1

Share this post


Link to post
Share on other sites
16 hours ago, B32B said:

Same issue over here. When I try to install ettercap manualy I receive the following error message:

opkg install ettercap
Installing ettercap (0.8.2-1) to root...
Downloading https://www.wifipineapple.com/nano/packages/ettercap_0.8.2-1_ar71xx.ipk.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for ettercap:
 *      libnet1 *
 * opkg_install_cmd: Cannot install package ettercap.
 

Something about a missing or wrong libnet1 module/library. 

Anyone any idea how to fix this?

Thanks in advance.

Same issue here.

Share this post


Link to post
Share on other sites

Hi Everyone,

My apologies for taking so long on fixing the issue with missing libraries. I have just uploaded libnet0, libnet1, and libnids to our package repository. You should be able to install / run any packages now that require those libraries.

I have also made sure that these packages are included in the next firmware release (soon :))

Best regards,
Sebkinne

  • Like 2

Share this post


Link to post
Share on other sites

Hi there,

I am expecting the same issues as darkone, when trying to use SSLSplit on 2.0.2.. If I Access the used Scripts via Console via SSH, They seem to use  "openssl"-commands to generate certificates. However, the openssl-CLI-commands aren't included in v. 2.0.2. Is there any way to add this commands manually?

If this is fixed by the firmware-update, when this Update is planned? I just would like to know, because I try to use this in a showcase at the end of march.

Greetings,
Noti


P.S.: Sorry if this isn't the right Place to ask this... but since the original poster seems to have the same problem I thought It would be appropriate.

Share this post


Link to post
Share on other sites

THANK YOU!  @ Sebkinne

I could not for the life of me get ettercap and a few other modules installed.  I had to manually install  libnet1 before using the GUI to install the modules.

 

 

I just connected via ssh. 

opkg update

opkg install libnet0                          (Was up to date).

opkg install libnet1                          (was missing or needed update).

opkg install libnids                           (was up to date).

 

Afterwards I was able to install  using the module manager no problem.   Just in case anyone else is having a similar issue.

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×