Jump to content

Recommended SIM for 3G LAN Turtle


Recommended Posts

Can anyone recommend a carrier for the using the 3G LAN ??

I am currently a T-Mobile customer and could add a line but wanted to make sure I explored all options before just adding a line for basically data only.

 

Thanks for all the help! 

Link to post
Share on other sites
  • 2 weeks later...

I purchased a 3g sim card from t-mobile and the lan turtle did not recognize it at all. So unless somebody else has had success with t-mobile sim cards, I wouldn't recommend it. It would be nice if Hak5 published some documentation on this or would at least answer the questions in the forums....

Link to post
Share on other sites

Hi there,

We accept all GSM Sim cards by all carriers (also internationally).

Having used a t-mobile Sim during development, there should be no issues. 

The most common problem we see is users inserting the Sim card the wrong way around. Please verify that you are inserting it according to documentation (it's a bit less obvious). 

Link to post
Share on other sites
  • 1 month later...
On 2/7/2018 at 12:58 PM, wytshadow said:

I purchased a 3g sim card from t-mobile and the lan turtle did not recognize it at all. So unless somebody else has had success with t-mobile sim cards, I wouldn't recommend it. It would be nice if Hak5 published some documentation on this or would at least answer the questions in the forums....

Story of my life when dealing with products from Hak5... documentation is always lacking.

Link to post
Share on other sites

Worked for me, Like Seb says the "tricky" part is installing the sim as its not the direction that you would perhaps expect it to be https://packetsquirrel.com/lt3g-sim.webm

I looked up my providers APN settings, popped them in to the 3G using the turtle interface, saved,  rebooted, and it was working.

https://www.hak5.org/gear/lan-turtle/docs

 

 

Edited by Just_a_User
Link to post
Share on other sites
  • 8 months later...

Okay. if HAK5 Tested with a T-Mobile SIM, then why haven't they posted the APN information they used????? 

When I went to T-Mobile's web side for APN settings its says to leave EVERYTHING blank but the APN and DNS address

This doesn't WORK at all.  COME ON HAK5....lead by example instead of saying we used t-mobile during dev and it works okay.

What EXACTLY worked okay?

What fields did you populate?

The fields that you populated what VALUES did you use?

200 dollar piece of equipment and nothing really but a short video that says how to put the SIM card in. 👿


image.png.7c656fd9081f1e358fe0bf64406d7c82.png
 

Link to post
Share on other sites
8 hours ago, mule said:

The fields that you populated what VALUES did you use?

I dont use t-mobile so cant test - but i had a look. it might not work, but this is what i found while searching for t-mobile APN.

"APN: Fast.t-mobile.com (for LTE devices) or epc.tmobile.com (for non-LTE devices)" - source

As the LanTurtle-3G is indeed 3G (and not a LanTurtle-LTE) i would imagine that "epc.tmobile.com" is the APN you are looking for.

Worth a try.

  • Like 1
Link to post
Share on other sites
5 hours ago, mule said:

I've tried both epc and fast tmobile.com APN's and still no luck.

I found one post that said they had to use tmobile DNS for it to work for them with epc.tmobile.com

66.94.9.120
66.94.25.120

 

again, maybe worth a try.

Also check your rebooting after each test? and to test internet access your doing what? I find a ping from my turtle ssh to google is best for testing LT-3G. Also check you dont have a sim PIN set, but you should be able to see/test that if using the sim on a mobile phone. You do have good signal?

Hope you figure it out. Gotr mine working with my APN really easy by doing similar things.

Link to post
Share on other sites

I was able to get mine working with tmoble with no settings. Once I got the sim in the correct way it just worked. When I go to the Turtle Interface and look at the Config 3G Modem all I see is 8.8.8.8 for DNS and 120 for Fallback time. The rest are blank. I am able to ssh to it from a vps with no network cable plugged in.

 

What does the enable wan fall back do?

Link to post
Share on other sites

Audrick,

I think the WAN Fallback is for if the 3G connection isn't available, the LAN turtle will attempt to use the WAN connection.

When you SSH to the are you using a 172.16.85.1 address? If so I think that works if the LAN turtle is plugged into a USB port on your local machine. 
If you aren't connected to the USB, would you mind sharing how you got the IP address of your 3G connection?

Link to post
Share on other sites

Mule, 

Thanks for the info on the Wan Fallback. 

I had setup my turtle with the auto ssh module. I have it plugged into a USB power supply and no other connections for testing. So from there I am able to reverse from my VPS. I did config it originally with the 172 address. Thats how I was able to confirm that it's working. I did have the sim in backward the first time. I had put the bent edge in first. Once that didn't work I consulted the documentation and found out the the bent edge sticks out I was all good. 

 

Link to post
Share on other sites
On 12/5/2018 at 8:57 PM, Audrick said:

I was able to get mine working with tmoble with no settings. Once I got the sim in the correct way it just worked. When I go to the Turtle Interface and look at the Config 3G Modem all I see is 8.8.8.8 for DNS and 120 for Fallback time. The rest are blank. I am able to ssh to it from a vps with no network cable plugged in.

This is often suitable for most carriers, as the APN, Username, Password etc are pulled from the carrier upon connection attempt.

On 12/5/2018 at 8:57 PM, Audrick said:

What does the enable wan fall back do?

As @mule correctly speculated, if there is a lack of 3G connection it will use the RJ-45 connection for internet.

Link to post
Share on other sites
3 hours ago, mule said:

image.png.0340f0e3c235bc8556a28f9e437445bc.png

 

In case you didn't know, you can improve how the shell looks by specifying the correct char set for the session. (I assume you are using PuTTY on Windows as this is the only place i've seen the issue.)

putty-1.png

  • Like 1
Link to post
Share on other sites

Foxtrot,

 

Thanks for confirming my speculation concerning the WAN Fall Back option.  I know I should change my putty settings for HAk5 shells, just too lazy to do it. Thanks for pointing that out for others if they were wondering why my shell window looked different.

  • Like 1
Link to post
Share on other sites
On 12/4/2018 at 4:35 PM, Just_a_User said:

I dont use t-mobile so cant test - but i had a look. it might not work, but this is what i found while searching for t-mobile APN.

"APN: Fast.t-mobile.com (for LTE devices) or epc.tmobile.com (for non-LTE devices)" - source

As the LanTurtle-3G is indeed 3G (and not a LanTurtle-LTE) i would imagine that "epc.tmobile.com" is the APN you are looking for.

Worth a try.

I can confirm this. Leave everything else blank. Well except for DNS settings cloud flare is reccomended at 1.1.1.1 or 1.0.0.1 as a secondary.

Link to post
Share on other sites

Can anyone confirm the /etc/config/network settings below are valid?

 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '172.16.84.1'
        option gateway '172.16.84.84'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option metric '30'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'
        option metric '20'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'
        option metric '20'

config interface 'vpn'
        option ifname 'tun0'
        option proto 'dhcp'

config interface '3gwan'
        option device '/dev/ttyACM0'
        option proto '3g'
        option service 'utms'
        option dns '66.94.25.120'
        option apn 'epc.t-mobile.com'
 

Link to post
Share on other sites

Mule

Turns out my Turtle was running V4. I updated and the 3g stoped working. I added the settings you found and posted above and I was back in business. Thanks for posting them. I didn't realize mine didn't ship with v5. You did mention that you were using V5 in your first post. I should have checked. Oh well. I now have C2 working and my devices showing up in it. 

My only turtle task left is to figure out some setting so that I can use the 3g over the USB. effetely making it a USB modem. Seems better than killing my phone battery. Oh well that's for another night. 

 

A

 

 

Link to post
Share on other sites

Mule

I have 2 Turtle 3Gs. Both are running V5. Both tested plugged into a USB power adaptor with no network cable. SSH in using the Auto SSH module and my VPS. Both have T-Mobile cards.

config interface '3gwan'
    option device '/dev/ttyACM0'
    option proto '3g'
    option service 'umts'
    option dns '8.8.8.8'
    option metric '10'
    option disabled '0'

 

config interface '3gwan'
    option device '/dev/ttyACM0'
    option proto '3g'
    option service 'umts'
    option metric '10'
    option disabled '0'
    option apn 'epc.tmobile.com'
    option dns '66.94.9.120'
 

The second is the new one and the 3G didn't work after v4 to v5 update until I used the apn and DNS from your above post. 

 

A

Link to post
Share on other sites

Audrick

 

Thanks,  I appreciate it. I tweaked mine and couldn't get to get an IP address from t-mobile any longer. Sadly, I had not made a backup before I made my tweaks and my memory wasn't spot on as usual. Your /etc/config/network details have restored my 3G LAN Turtle to full working order!

This is the one I used.

 

config interface '3gwan'
    option device '/dev/ttyACM0'
    option proto '3g'
    option service 'umts'
    option metric '10'
    option disabled '0'
    option apn 'epc.tmobile.com'
    option dns '66.94.9.120'

M

Link to post
Share on other sites
  • 1 month later...

I got my google fi data only card today and put it in my turtle 3g. I added APN: h2g2 per google settings and I changed the dns from the T-Moble ip to 8.8.8.8. Worked after a hard plug. Typing reboot in the terminal didn't work. I am able to reverse shell into it while its plugged into a USB power supply with no cable attached. Great hardware. 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...