Jump to content

OpenVPN question


Exmix
 Share

Recommended Posts

So question with the packet squirrel OpenVPN, I have my client openVPN file on it, does it need to be named Client.ovpn or should it stay the client name? Eg Exmix.ovpn, and on that client, should there be a password? Usually when connecting to an OpenVPN server it asks for a password.

Link to comment
Share on other sites

48 minutes ago, Dave-ee Jones said:

It's just 'client.ovpn'.

You can clarify by looking at line 46 of the payload.sh.

The file is generated by the OpenVPN server when you create it (or ask for it to be generated after you create the server), I believe.

Right, so I have my OpenVPN server on my RaspberryPi, I made the client client, move the client to the squirrel and have it named "client.ovpn" but then my question is, does the client need to not have a password or...? Because usually when I have it and connect it through my Linux or Windows system, i'm asked for a password.

Link to comment
Share on other sites

23 hours ago, Exmix said:

Right, so I have my OpenVPN server on my RaspberryPi, I made the client client, move the client to the squirrel and have it named "client.ovpn" but then my question is, does the client need to not have a password or...? Because usually when I have it and connect it through my Linux or Windows system, i'm asked for a password.

I am very confused.

I think you're digging too deep into the 'config.ovpn' file. It's just the name of the file - that's all. It's not generated for a 'client'. It's generated for clients to connect to the OpenVPN server, but it it's not for a client named 'client'.

To be honest, I'm not 100% with the password. I heard a few things on similar topics before, but have a search around on the PS forums instead of making a new post about it, as there are quite a lot of them. Here's a few to get you started:

 

 

Edited by Dave-ee Jones
Link to comment
Share on other sites

6 hours ago, Dave-ee Jones said:

I think you're digging too deep into the 'client.ovpn' file. It's just the name of the file - that's all. It's not generated for a 'client'. It's generated for clients to connect to the OpenVPN server, but it it's not for a client named 'client'.

I assumed I would just need to make my own client file then copy it to the squirrel. I could be wrong on that. I will look into that more.

 

EDIT: I Think I found the issue. 1. I forgot to change my payload.sh to FOR_CLIENTS=1

2. I copied my .ovpn file to my turtle and had it named config.ovpn so it's all in there properly. I'll test tomorrow to make sure i'm connected and working

Edited by Exmix
Link to comment
Share on other sites

3 hours ago, Dave-ee Jones said:

Yeah, sorry I can't be more specific - I haven't tried to create an OpenVPN server yet. Although, there is a pretty detailed tutorial on how to get it running here, under "Default Payloads" and "How to use the Packet Squirrel OpenVPN payload".

Yeah I looked at that documentation before making this post. I have it all setup correctly. I have my OpenVPN Server setup andI can take the client.ovpn and put it on my phone for example and I can connect with it no issue. I move it to the Squirrel but keep it rename it "config.ovpn", as it says in the documentation. I changed my "FOR_CLIENTS=1" in the payloads.sh but I can't seem to get a connection. The light on my squireel blinks once and it's a yellow color. I can't find documentation on what that means.

Link to comment
Share on other sites

19 minutes ago, Dave-ee Jones said:

The LED turning yellow means that the payload has complete and the VPN should be running (LED ATTACK = LED Y).

Maybe check to make sure that the path to the 'config.ovpn' is correct in the 'payload.sh'.

the path i'm seeing is: uci set openvpn.von.config=${DIR}/config.ovpn

my DIR variable is: DIR=$(cd "$(dirname "${BASH-SOURCE[0]}")" && pwd)

Link to comment
Share on other sites

12 minutes ago, Exmix said:

the path i'm seeing is: uci set openvpn.von.config=${DIR}/config.ovpn

my DIR variable is: DIR=$(cd "$(dirname "${BASH-SOURCE[0]}")" && pwd)

Try using this method:

DIR=$(dirname $(readlink -f "$0"))
# Should take you to your switch folder

I doubt it will do anything but worth a shot.

Link to comment
Share on other sites

2 minutes ago, Dave-ee Jones said:

Try using this method:


DIR=$(dirname $(readlink -f "$0"))
# Should take you to your switch folder

I doubt it will do anything but worth a shot.

Ok i'll try that. Now since i'm currently on the same network as my OpenVPN server I won't be able to test until tomorrow unless there's a different way to test while on the same network.(That's something i've never looked into before actually haha)

Edited by Exmix
Link to comment
Share on other sites

17 minutes ago, Exmix said:

Ok i'll try that. Now since i'm currently on the same network as my OpenVPN server I won't be able to test until tomorrow unless there's a different way to test while on the same network.(That's something i've never looked into before actually haha)

All this is doing is making sure the shell script can see the file. Sometimes it gets a bit messy when the $DIR variable isn't set properly and doesn't work. However, there's a slim chance it didn't work otherwise Darren/Sebkinne would've picked up on it. Human error is always a factor, I suppose.

Link to comment
Share on other sites

  • 4 weeks later...

anyone have some decent understanding of ipv6 and openVPN? i've got a weird issue....

the short story: I created an OpenVPN server on my Odroid-c2. Everything worked. All my traffic was flowing over the VPN. I used this at work and when i traveled without issue. Flash forward about 3 months. I was between jobs and not using my VPN daily. Got a new job *(yay)* and fired up the VPN .. connected fine.. but then... no traffic... at least... no web traffic. I can still see my home network, that route was pushed fine. I can SSH into my odroid...i can ping my router... I took a look at my openvpn logs. noticed I was getting an error "OpenVPN route6: OpenVPN needs a gateway parameter for a --route-ipv6-option and no default was specified by either --route ipv6-gateway or ifconfig-ipv6 options" 

things i've tried: So I did some searching, found the openVPN page about ipv6 I was able to insert the line into my openvpn server config for server-ipv6 however.. i'm not sure i'm correctly adding the correct gateway address.. I can push the route.. but still get no web/ipv6 traffic passing over the tunnel. I've tried fe80::1 i've tried the ipv6 of my eth1 .. still nothing... it's so odd. i'm sure its something small i'm missing or just not using the correct address... but it's frustrating the hell out of me... 

 

anyone with a clue or point in the correct direction would be greatly appreciated.  

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...