Jump to content

Support for USB Tethering of Verizon MiFi® 6620L


amadeuspzs
 Share

Recommended Posts

Hello folks,

I am trying to get USB tethering of the Verizon MiFi® 6620L working on the nano for WAN access.

The device has been configured for USB tethering, and works on Mac OS X etc - plugging in the device forces the MiFi to ask what type of USB tethering to enable.

Plugging into the Pineapple Nano however (latest firmware) just charges, with no prompt for tethering and no network interface created.

Has anyone had any luck using this via USB?

root@Pineapple:~# lsusb
Bus 001 Device 009: ID 1410:b010 Novatel Wireless
root@Pineapple:~# usbmode -l
root@Pineapple:~#
root@Pineapple:~# lsusb -t
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-platform/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
        |__ Port 1: Dev 3, If 0, Class=Vendor Specific Class, Driver=ath9k_htc, 480M
        |__ Port 2: Dev 4, If 0, Class=Mass Storage, Driver=usb-storage, 480M
        |__ Port 3: Dev 9, If 0, Class=Human Interface Device, Driver=, 480M

I've tried this approach to no avail: 

Thanks!

Amadeus

 

Link to comment
Share on other sites

25 minutes ago, amadeuspzs said:

Has anyone had any luck using this via USB?

What interfaces do you see with an "ifconfig -a" from terminal? if you get a new interface your in luck and drivers are present. Then its just some /etc/config/ file tweaking. If you don't get an interface then its likely a driver issue.

Link to comment
Share on other sites

  • 1 month later...
  • 7 months later...

Interesting (and disappointing) - as I have been quite successful tethering this same hotspot (Verizon 6620L) to the Pineapple Mark V.  Was assuming (we know what happens when we assume things!) / counting on the same functionality with the Nano.

#Drats!

Link to comment
Share on other sites

4 minutes ago, SnoWake said:

Interesting (and disappointing) - as I have been quite successful tethering this same hotspot (Verizon 6620L) to the Pineapple Mark V.  Was assuming (we know what happens when we assume things!) / counting on the same functionality with the Nano.

 #Drats!

We'll check out what the driver difference was and see if we can get it working again!

Link to comment
Share on other sites

Wow - now that's what I call a responsive Head of Development!! ?  Thanks for the instantaneous response, @Sebkinne!

In the meantime, I'll experiment with some wireless adapters, and see if I can at least get it to connect to the hotspot in client mode.  Less ideal than tethered - but definitely beats ICS over USB! ?

Thanks again, and hope you're having a great weekend.

 

Link to comment
Share on other sites

If you connect it to a wndows machine first. The trouble shoot connection ( via usb tethering) i have this same one too but i use on Bell network via apn. I like this model because you can use sim cards other than verizon. I was having linux probs too. Then i do this it works. ???

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...