Jump to content



Recommended Posts

Hello to all.  I am hoping someone may be able to provide some insight on an item within TRK which is extremely vague and unsupported.


There are these utilities which will image a backup of your entire system but the RESTORE aspect is extremely vague.  In fact there's a menu item to backup but no menu item to restore.

I ran unpi on the console and essentially it is extremely confusing.

Rather than using target and source or source and destination is has "archive" and "directory" which if you can make sense of that, kudos.

I tried all combinations of dev1,2,3 and using archive and source.


What's strange is the partitions listed show the internall HDD and the USB HDD however UNLIKE pi, unpi doesn't ever see the USB HDD when you're selecting the 'source' and 'destination'


Either way can anyone please assist me?

I am in a bind professionally.  This is a time sensitive item and I must get this restored asap.


I have the image spanned across a bunch of 2GB files each with an incremental numeric extension.


I can even restore to a VMware vm if needed or if possible (which would be GREAT) convert this backup to some other format.  Ghost image would be my main preference.

Here is the byproduct of pi's backup:






Inside folder:

2017-12-22-I-sda2.000 through to 2017-12-22-I-sda2.054

107GB total.

Target drive is 128GB

Drive that was imaged was 250GB


I either get a choice of folders to pick from to find the backup that aren't the USB HDD or it gives me some kind of error talking about midnight commander causing the problem

"If you ran unpi in midnight commander this may be the issue" however I haven't done that. I loaded shell and rand it.





Link to comment
Share on other sites

There is a utility in Raspbian that will duplicate your system to another SD card one that is mounted in a USB adapter.   I know nothing of TRK but that's how I back up my Pi.  Also the "Win32 Disk Imager" which I used to make SD card's for the PI, does the same thing, making an image from the disk which you store as a file.   What might be jamming you in all cases, you can't create a disk image to a medium smaller than the disk.   So - you can't put a 250gb image on a 128gb card.  You can put a 250gb image on a 250gb file on your PC, then Zip it.  I might add, I do just fine with a 32gb card on my PI, using a thumb drive for "big stuff" when that comes up.

Restore would simply be a matter of using that second SD card instead of the first.

Edited by Struthian
Link to comment
Share on other sites

If the OS is Raspbian or even Debian, then it's all still true.  A disk image is a disk image, that is to say, it represents the entire image of the disk.  I don't know of a non image backup - though it might exist.  A non image backup is complicated by creating the appropriate  partitions within the disk  and then restoring the proper files to those partitions.   All this is exactly why (in addition to saving money) I use SD cards that are just enough to fulfill my needs.  If that need increases, I step up to a larger SD card, restore to that and then expand into it. 

Link to comment
Share on other sites

Ok so just to make sure I have an idea.


You have a computer, running windows 7, that you created a backup of using TRK and saved to another disk, not the main windows one, like a whole other disk? Or was it saved to another partition on the same physical disk?

So if the backup is on a whole other physical disk, and you wish to restore from the images on that second disk wiping out windows and restore it to the state it was in when the backup was made, is that accurate?


Link to comment
Share on other sites

Yes that is a correct assessment.  Sorry if this was not clear before.. Scrambling for a solution to get this re-imaged to the new PC. It's an executive's laptop! :S


I know a lot of people may be wondering why..


I had an extreme time crunch.  NONE of the boot PE environment discs would be able to see the internal HDD.

This is one of those new laptops that has a very funky drive type and controller.  Similar to when SATA came out and none of them could read the drives.

Later they baked in a layer which would be able to do UEFI and the like.


As far as this system is concerned  I do not know the specific drive type but it's an "SSD" although it really isn't it's just a proprietary RAM stick in a socket that may be standardized.

It shows as SATA in bios but we know that cannot be the case as it's not compliant at the bios level. Only at the OS layer.  The hardware controller and BIOS are obviously able to see the drive at this pre-boot state however utilities cannot.


TRK was the ONLY utility that I tried out of 8 which could see the drive.

Falcon Four

System Rescue



and a few others could NOT.


So I know you're wondering why I'd use TRK or PI to do this backup but literally it was all that was able to see the drive.

It's a Samsung 900x laptop with a 128GB drive

the source was the same but a 250GB drive.

Here's the partition info txt file:

Disk /dev/sda: 256.1 GB, 256060514304 bytes
255 heads, 63 sectors/track, 31130 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xba2c4f98

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      102400    7  HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2              13       28950   232429568    7  HPFS/NTFS
/dev/sda3           28950       31131    17525760   27  Unknown

Disk /dev/sdb: 2000.4 GB, 2000365289472 bytes
256 heads, 63 sectors/track, 242247 cylinders
Units = cylinders of 16128 * 512 = 8257536 bytes
Disk identifier: 0x16f2a91f

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1      266306  2147483647+  ee  GPT


and the config file:


# No space before and after the = sign
# The names are case-sensitive
# No backslashs: \, only slashs/

# Destination backup unit. It may be a network drive, for example:
# In this case the parameters LOGIN and PASSWORD are required
# Or a local unit such as BACKUPDRIVE=/sdb1

# Backup directory
# Partitions to backup
# If there are multiple partitions, separate them by spaces,
# and put it between quotation marks
# Example PARTITION = "sda1 sda5"
# If AUTO=1 and a pi.cfg configuration file was found
# the backup is done without any user intervention

Edited by kevinflynn
Link to comment
Share on other sites

The total size of the backup is 107GB.


Oh to clarify and be specific to answering your questions...

1)Taget laptop 900x samsun 250GB SSD HDD

2)Destination was a USB 2TB connected to the same system.  The backup was of the entire PC to a folder and subsequent spanned 2GB files. it totaled 107GB

The output folder was "BACKUP"

inside were the following:




FIle: partition-info.txt

File; pi.cfg

Inside folder:

FILES: 2017-12-22-I-sda2.000 through to 2017-12-22-I-sda2.054

Presumably the actual backup data itself.

Edited by kevinflynn
Link to comment
Share on other sites

I normally just use Falcon and Ghost.  This was the closest I could find without really knowing anything about it or having any prior experience.

I was wondering why it was called PI.  I am hoping to god that it being specific to raspberry pi that it is capable of doing what I did.

Either way, the restore process is not as comprehensive as the backup process was.


Link to comment
Share on other sites

Honestly reading down through the config file, it doesn't match what you've said regarding the drive sizes at all.... I see a 256gig drive, sda, and I see an almost 2TB drive (2000.4 G) drive sdb.

But I see nothing regarding a 128gig ssd.

Jumping into using TRK when not 100% certain on what you were doing was a bad move (which you clearly now know). Your best bet is to ask on the TRK forums or boards, rather than here.

Also for future backups off UEFI SSDs on that particular device, try something like Macrium relfect. It's very simple and easy to use, and lets you create boot media to restore from.

EDIT: Sorry, let me apologise and correct myself. I see you want to image TO a 256gig, not to a 128. That's totally my bad. I am sorry.

I did a bit of quick digging, and boy do I mean quick, if you boot from TRK on the new machine, with the external drive linked up, you should be able to use unpi to "restore" to the 256gig new one. In theory. I haven't tried it myself so can't be certain.

Edited by Rkiver
Link to comment
Share on other sites

no problem.  I wouldn't say I didn't know what I was doing at all.  Just that the utility was all I had that would work.

The restore process was somewhat convoluted but I figured it out "restore disk" is the TARGET and archive disk is the SOURCE.


Either way I got it to work.  Now my only challenge is to get it to boot.  The files are all there but it didn't backup the boot partition just the primary NTFS one.

Not a big deal at all.


What this boils down to is if it were some regular laptop like a latitude and had a built in CDROM drive I'd never even had to have posted here!

Turns out the stupid llaptop is really weird.  It's BIOS is not PE friendly at all.  The CSM mode and the USB ports are not compliant.


Essentially what happened was the left USB port would not show any devices connected.  What tipped me off is when I switched the USB HDD and the USB CDROM (because this piece of garbage has no CDROM) then TRK could NOT BOOT!!! It wouldn't see the CDROM drive once the kernel was loaded. 


So I went to my trusty dell and restored to a brand new HDD just fine.

I am about 90% there.


What I will do is take my good HDD which has windows 7 on it already, and boot to falcon and copy all of the files over from my image.

After that I should be good.

I will let you know the outcome.


So none of this was UNPI related it was because the system in question is junk.  When I tried on my dell it worked perfectly first run.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...