Jump to content


Recommended Posts


I got this WiFi Pineapple-NANO for christmas and I'm trying to get it set up correctly..I plugged it in, followed the instructions and started to update the firmware, the blue light didn't start blinking at all as I pressed upgrade, so I decided to unplug it and try again.

Now when i plug it into my computer it blinks once, turns solid blue for about 3-4 seconds and then the light goes out.

I have tried to follow the instructions on https://www.wifipineapple.com/pages/faq for firmware reset without luck. But I do realize I might be doing something wrong, as I simply go to my routers control panel as I browse to

I do have 'Bus 001 Device 018: ID 0b95:772a ASIX Electronics Corp. AX88772A Fast Ethernet' under lsusb so I know its recognized, but as far as I can tell it only recognizes  it if I'm NOT holding down the reset buttom as i plug it in.

Can anyone please tell me where I go from here?

Link to comment
Share on other sites

From what I'm reading after you updated the firmware it never came up right? Did you ever see it in your wifi network? I know when I did my update the only way I knew it was done was to check my wifi networks around me. What you could do is try to reload the firmware once again and letting it load . Trying doing this  but download the firmware first . The most current one is 2.0.2 

  • Unplug the WiFi Pineapple completely from all power sources.
  • Begin holding the RESET button on the device.
  • With the RESET button held, power on the device.
  • Continue holding the RESET button for 10 seconds, then release.
    • NANO: The blue LED will remain solid
  • From the host PC, configure a static IP address on the WiFi Pineapple facing Ethernet interface to with netmask
  • From the host PC, browse to
  • Click Choose File and select the factory firmware image downloaded above.
  • Click Update Firmware.
  • This process will take several minutes. Do not interrupt the power supply while the firmware is updating. Once complete, the WiFi Pineapple will restart.
  • Reset the the WiFi Pineapple facing USB Ethernet interface back to DHCP or with netmask
Link to comment
Share on other sites

Thanks for the fast answer.

I've tried what you requested (if I understood correctly) and unplugged the pineapple, hold down the reset buttom and plugged it back in. I keep holding it till I get a solid blue light. When this is done, I can see 'USB ethernet' connecting, but it never connects, also I can't see any new wifi signals. Same result if I just plug it in, without holding down the reset buttom?

I'm not sure if the firmware ever was updated, I feel like the pineapple aren't even booting fully up?

Link to comment
Share on other sites

not sure if im along the same lines here but its sounds similar to a windows issue i got when first setting up my nano,i had to disable windows firewall if i remember rightly as it was not allowing me to share connection, cant really remember now as it was a while ago

Link to comment
Share on other sites

  • 3 years later...


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...