Jump to content

Putting ASRock USB WiFi dongle in monitor mode


Recommended Posts

I bought an ASRock USB WiFi dongle from HAK5 recently. I'm using on my XPS13 running Ubuntu 17.04.

When I plug it in and do an ifconfig it returns as wlx002522508b5d

If I then try and pit it in monitor mode using

sudo airmon-ng start wlx002522508b5d

The device then vanishes from the ifconfig list and I get 

phy0 wlan0 wl Broadcom Limited BCM4352 802.11ac Wireless Network Adapter (rev 03)
phy6 wlx002522508b5d rt2800usb Ralink Technology, Corp. RT2870/RT3070
Interface 15mon is too long for linux so it will be renamed to the old style (wlan#) name.

(mac80211 monitor mode vif enabled on [phy6]wlan1mon
(mac80211 station mode vif disabled for [phy6]wlx002522508b5d)

I then try

sudo wash -i wlan1mon

it returns  

 

wash v1.4 WiFi Protected Setup Scan Tool
Copyright (c) 2011, Tactical Network Solutions, Craig Heffner <cheffner@tacnetsol.com>

[X] ERROR: Failed to open 'wlan1mon' for capturing


I have tried substituting wlam1mon for [phy6]wlan1mon, [phy6], [phy6]wlx002522508b5d, wlx002522508b5d and they all return the Failed to open error.

Where an I going wrong please?

Thanks for any help

 

Edited by entropy1024
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...