Jump to content
Hak5 Forums
azzy9

Canon Connect Station CS100

Recommended Posts

On 6/11/2018 at 4:16 PM, Valo88 said:

Brilliant! Can you please explain how? What software did you use?

used Ubuntu 14 , DISKS utility to back up individual partitions 

after backing up the existing partitions 

1. Format hDD in MBR

2. Need to create partitions in bytes according to your size of the backed up image partition ,first 3 partitions  1gb ,256 mb swap, 128mb partitions

 for eg mine

  • Partition 1: Main OS   (1000000512 Bytes )
  • Partition 2: swap(256000512 bytes)
  • Partition 3: System Sounds ( .wav & .m4a )(128000512  bytes)

3.now create a extended partition of remaining hdd and create 4 partition

  • partition 4:System Update Scripts (4000000512 bytes)
  • partition 5:Logs (4000000512 bytes)
  • partition 6:System Config (8000000512 bytes )
  • partition 7: Own Media ""create rest of the partition and format it with ext4

put every thing back and start the devices and format hdd from options 

Share this post


Link to post
Share on other sites
22 minutes ago, venkat5979 said:

used Ubuntu 14 , DISKS utility to back up individual partitions 

after backing up the existing partitions 

1. Format hDD in MBR

2. Need to create partitions in bytes according to your size of the backed up image partition ,first 3 partitions  1gb ,256 mb swap, 128mb partitions

 for eg mine

  • Partition 1: Main OS   (1000000512 Bytes )
  • Partition 2: swap(256000512 bytes)
  • Partition 3: System Sounds ( .wav & .m4a )(128000512  bytes)

3.now create a extended partition of remaining hdd and create 4 partition

  • partition 4:System Update Scripts (4000000512 bytes)
  • partition 5:Logs (4000000512 bytes)
  • partition 6:System Config (8000000512 bytes )
  • partition 7: Own Media ""create rest of the partition and format it with ext4

put every thing back and start the devices and format hdd from options 

 

Share this post


Link to post
Share on other sites

Is it possible to replace another smaller hard drive to be used for canon cs100? what i am trying to ask is how to make another hard drive configured to be used in canon cs100, What would be the procedure?

Share this post


Link to post
Share on other sites
10 hours ago, Karankaiju said:

Is it possible to replace another smaller hard drive to be used for canon cs100? what i am trying to ask is how to make another hard drive configured to be used in canon cs100, What would be the procedure?

I want to swap 1tb hdd with 80gb hdd in canon cs100.

Share this post


Link to post
Share on other sites

I just bought 3 pcs. Canon CS100. They came with old software 1.*.* Telnet is enabled by deffault. Should I update to new firmware or I can try instal Debian on this version? I just backup entire image of the HDD with the stock firmware. Please gve me some advice and excuse my bad English.

Share this post


Link to post
Share on other sites

My is with firmware 1.1.2 and the Telnet was enabled, but I can't connect to port 23, so I run port scanner. Here are the results:

HTTP

CS100

Port 8089 (TCP)

 

Port 9901 (TCP)

 

Port 9903 (TCP)

 

Port 9910 (TCP)

 

Port 9930 (TCP)

 

Port 15740 (TCP)

 

Port 30000 (TCP)

 

Port 49152 (TCP)

Portable SDK for UPnP devices 1.6.18 Linux 2.6.35.9-32-sigma; UPnP 1.0

Port 60000 (TCP)

 

Share this post


Link to post
Share on other sites

I have updated one unit to 2.5.2, but after moddification of line 200, telnet is not working, after restart and putung hdd off the unit, the line was telnet=no again. So I find this comment in the file:

# this line gets modified at build time on some builds
# so if it looks like this stuff is always enabled, it's not...

Share this post


Link to post
Share on other sites
On 7/29/2018 at 8:25 AM, duronman said:

I have updated one unit to 2.5.2, but after moddification of line 200, telnet is not working, after restart and putung hdd off the unit, the line was telnet=no again. So I find this comment in the file:

# this line gets modified at build time on some builds
# so if it looks like this stuff is always enabled, it's not...

Hi duronman,

I believe when it talks about build time, it means the compilation process before it goes onto the machine, not during run time.

Not sure why it is not working for you but have you tried chown the file before you modify it?

also please double check that it is the canon station modifying the file, and there are not some write issues while changing the telnet variable.

if it does continue to change, you could try removing write permission on the file so then the cs100 cannot touch it.

 

Hope all goes well for you ?

 

Share this post


Link to post
Share on other sites
On 8/3/2018 at 11:34 PM, azzy9 said:

Hi duronman,

I believe when it talks about build time, it means the compilation process before it goes onto the machine, not during run time.

Not sure why it is not working for you but have you tried chown the file before you modify it? 

also please double check that it is the canon station modifying the file, and there are not some write issues while changing the telnet variable. 

if it does continue to change, you could try removing write permission on the file so then the cs100 cannot touch it. 

 

Hope all goes well for you ?

 

Thank you very much! Is it confirmed, that SAMBA will work and also is it any chance softwares like transmission to work? Thanks again!

Share this post


Link to post
Share on other sites
On 1/16/2018 at 9:31 PM, azzy9 said:

That would be awesome ?

 

 

I have figured out how to get telnet working on it.

1. Connect the HDD to a linux system and mount the partitions

2. chown file "etc/rc.d/rcS" on 1st partition

3. open file "etc/rc.d/rcS"

4. find the line with content: "allow_telnet=no" and change it to "allow_telnet=yes" (was on line 200 for me)

5. save the file, then set canon station up with the Ethernet port used to connect to router

6. use application to connect to telnet on port 23 with username as "root". no password required. (I used putty on my windows laptop)

Hope this helps.

 

 

I can not mount the HDD on Ubuntu which is connected via usb adapter to my laptop.

Please create a tutorial with the necessary steps to be able to mount the first partition to get telnet working.

Thanks!

Share this post


Link to post
Share on other sites

Can someone with successful mod, upload a compressed image of the HDD (Free and easy with Macrium Reflect). I think this can be really helpful. The image is few GBs.

Share this post


Link to post
Share on other sites

I've followed the @nimrud tutorial (https://github.com/dtrigo/canon-cs100) it woks! But now, I need to upload video or pics into the fucking cs100 using "scp" or "nfs", but it's not easy and, later, visualize it over HDMI in my TV. First of all, the normal upload process changes the names of the files. Because of this, I can't see my uploaded videos using HDMI. Anyone knows which are the steps or which is the crypto algorithm to generate the names? Thanks!

Share this post


Link to post
Share on other sites

Hi guys!

Also bought 3 pcs at 50$ each. I am trying to make an hdd image on my windows pc, but it seems windows gets stuck in the kernel when trying to start aomei backupper. I tried both a sata usb adapter, but aomei backupper doesn't (gets stuck in loading) and windows then gets stuck in 'shutting down' and mounting the hdd directly on the mobo, but then windows gets stuck either in starting screen in one port or behaves exactly like the usb adapter in the other. I tried updating the bios and drivers, turning the antivirus off, but nothing changes. Tried with another hdd and it behaves normally (windows and aomei don't get stuck). I also mounted the hdd with the usb a

Share this post


Link to post
Share on other sites

I also mounted the hdd with the usb to my laptop and I don't these symptoms, even with the av turned on. Any ideas what would cause this? I really want to back up the original CS100 image before doing any mods.

 Thanks! 

Share this post


Link to post
Share on other sites

I used Partitionguru to reduce the size of the media partition from 905GB to like 50GB and then saved the entire drive as an image.. Used the smaller HD to copy back the saved image with like EaseUS todo since that works with ext partitions and saves it in a compressed format and put it back in the CS100 and it works fine.. I have not been able to fill the drive with more than 100GB since most media is not compatible and wont be copied.

  • Like 1

Share this post


Link to post
Share on other sites

You have to use a program that compresses the image files since this is a 1TB drive and it should use up around 5GB once compressed. Also since they are ext partitions, you also need a program that at least works somewhat with more than NTFS and MBR partitions and I used EaseUS todo backup, had trouble with AOMEI images.. Partition Guru will allow you to edit files on the drive and even copy them etc.. But the media is saved in thumbnail format and under its own names and system and not its original name and in many versions. 

 

To use a smaller HD, you have to make the media partition smaller using like partitionguru first and then save the image.. Otherwise you need a EXT compatible image copier as it will just copy sector by sector and then wont work for different sized HD's to the created image.. The 1TB image file will not fit on a 100GB HD and need a HD larger than 1TB (this is important) the 1TB created image wont fit back onto the 1TB HD you copied it from, you need like a 2TB HD to copy back the image.. So if you plan to ever reuse the drive or the CS100, reduce the partition size and save the image file. You can ofcourse CLONE the 1TB HD to another 1TB HD..  So I had to get a 2nd CS100 to clone the HD to get it working again as the image could not be written back to the 1TB drive.

 

 

  • Like 1

Share this post


Link to post
Share on other sites
26 minutes ago, MILLANAZGUL said:

 


Hi, I have been able to move to a smaller hdd. Use trueimage, create an image and put it to the smallest, indicating that the partition to reduce is the largest.

 

https://youtu.be/alJzxfNrv1k

Thanks

 

Share this post


Link to post
Share on other sites

Can someone tell me about samba network performance after the hack. Can it handle at least 20-30 MB coplyng speed ? Can the device handle transmission, or some lite PHP, nextcloud etc?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×