Jump to content

Nano on Google Pixel 2


Tech_Terry
 Share

Recommended Posts

Has anyone had been able to get the Nano to work on the Pixel 2? I downloaded the latest Android app on the Pixel 2 XL and flashed the Nano with the latest firmware.

I started the Android Pineapple app on the Pixel 2 XL, attached the Nano by a USB cable and enabled USB tethering, but I never get past "Waiting for connection".

The Nano works attached to my laptop, so I don't think there is a issue with the nano.

Has anyone had success with the Nano on a Pixel 2? 

Thank you for any input or suggestions.

Link to comment
Share on other sites

Thanks. 

 

IF you had said it should work, I would have ordered another Nano. Instead, I will get the Tetra, for when SIZE is not important, or I need 5GHz.

Will future support showup as a app update on the Google Play Store?

Thanks for the quick response.

Edited by Tech_Terry
Link to comment
Share on other sites

  • 4 weeks later...
2 minutes ago, cyrus104 said:

I'm in the same boat with a stock Pixel 2 and a Nano.

The phone starts to charge from the Nano but the USB tether option is greyed out and the Pixel doesn't see a device just power.

 

Thanks

I still haven't had the chance to work on the app / look into what changes need to be made to support the newer Android phones. 

  • Upvote 1
Link to comment
Share on other sites

  • 1 month later...
  • 4 weeks later...
On 12/24/2017 at 2:57 PM, Sebkinne said:

I still haven't had the chance to work on the app / look into what changes need to be made to support the newer Android phones. 

Yeah, when will support hit Google Android's flagship phone? :(
I bought it just for my Pixel 2. 
(T.T)

  • Like 1
Link to comment
Share on other sites

  • 5 months later...

I have Google Pixel 2 and I am using Android Pie. Make sure you are giving the power to the WiFi Pineapple NANO while you are connecting a USB cable to USB Host port. At first I though, I can just straight connect WiFi Pineapple USB connector through USB OTG cable, I was dumb a bit then. Also, you need to disable Android's Exclamation Mark (No Internet) detection in order to be able to connect to the WiFi Pineapple management access point, as the Android blocks network traffic if it can't ping Google servers (if there is no internet connection). To do so, take a look at https://android.stackexchange.com/questions/100657/how-to-disable-captive-portal-detection-how-to-remove-exclamation-mark-on-wi-fi Oh and, if you are stuck at Waiting for WiFi Pineapple to make a connection, make sure to wait until the Pineapple boots as it won't straight away connect, when the light stops blinking, connect the USB cable and follow the app's instructions.

Edited by moliata
  • Like 1
Link to comment
Share on other sites

On 8/26/2018 at 11:38 AM, moliata said:

I have Google Pixel 2 and I am using Android Pie. Make sure you are giving the power to the WiFi Pineapple NANO while you are connecting a USB cable to USB Host port. At first I though, I can just straight connect WiFi Pineapple USB connector through USB OTG cable, I was dumb a bit then. Also, you need to disable Android's Exclamation Mark (No Internet) detection in order to be able to connect to the WiFi Pineapple management access point, as the Android blocks network traffic if it can't ping Google servers (if there is no internet connection). To do so, take a look at https://android.stackexchange.com/questions/100657/how-to-disable-captive-portal-detection-how-to-remove-exclamation-mark-on-wi-fi Oh and, if you are stuck at Waiting for WiFi Pineapple to make a connection, make sure to wait until the Pineapple boots as it won't straight away connect, when the light stops blinking, connect the USB cable and follow the app's instructions.

Thanks Mliata! I'll try this.

Link to comment
Share on other sites

4 hours ago, moliata said:

Sure, I just missed to say that you also need to turn off your Mobile Data if you are connecting to the WiFi Pineapple Management AP (through WiFi) and not Connector app.

Ah, thanks for that. Rooting the pixel and disabling the exclamation mark has been a hurdle too. 

Link to comment
Share on other sites

8 hours ago, moliata said:

Sure, I just missed to say that you also need to turn off your Mobile Data if you are connecting to the WiFi Pineapple Management AP (through WiFi) and not Connector app.

Unless you turn on "simultaneous networks" or whatever it's called in the Developer menu on Android. It's something like "don't turn off data if I'm connected to WiFi" or something..

May work, probably not but might be worth a shot.

Edited by Dave-ee Jones
  • Like 1
Link to comment
Share on other sites

43 minutes ago, Dave-ee Jones said:

Unless you turn on "simultaneous networks" or whatever it's called in the Developer menu on Android. It's something like "don't turn off data if I'm connected to WiFi" or something..

May work, probably not but might be worth a shot.

Thanks Dav-ee > I turned off "Mobile data always active" that's the closest I could find. Still working on getting this to work.

Link to comment
Share on other sites

4 hours ago, Dave-ee Jones said:

Unless you turn on "simultaneous networks" or whatever it's called in the Developer menu on Android. It's something like "don't turn off data if I'm connected to WiFi" or something..

May work, probably not but might be worth a shot.

That's not what I mean, when you connect to the Management AP (...and if it doesn't have internet connectivity, Android tries to ping Google servers). This results in "no response" and so, Android blocks all internet connectivity, including the 172.16.42.1. Disabling the Mobile Data, Google can't ping and see whether the response differs, it then allows internet traffic.

Well, you shouldn't have rooted your phone, it works without it? Disabling the exclamation mark is done using adb. Simply download Android SDK tools, which should have adb tool, connect your phone and type "adb shell", which will start a shell with your phone, then you can type those commands. I mean, I didn't need root for this.

Link to comment
Share on other sites

18 hours ago, moliata said:

That's not what I mean, when you connect to the Management AP (...and if it doesn't have internet connectivity, Android tries to ping Google servers). This results in "no response" and so, Android blocks all internet connectivity, including the 172.16.42.1.

172.16.42.1 isn't on the internet side, though.

What you're saying is it blocks all network access if it can't ping Google, which isn't true. I can access my local NAS when I don't have internet access on my Android (OnePlus 5T, latest firmware).

What's this "Management AP" you're talking about? Is it the Pineapple or something else?

18 hours ago, moliata said:

..This results in "no response" and so, Android blocks all internet connectivity, including the 172.16.42.1. Disabling the Mobile Data, Google can't ping and see whether the response differs, it then allows internet traffic.

Also, if you've got no internet on your WLAN side then wouldn't it fall back to mobile data?

18 hours ago, moliata said:

Well, you shouldn't have rooted your phone, it works without it? Disabling the exclamation mark is done using adb. Simply download Android SDK tools, which should have adb tool, connect your phone and type "adb shell", which will start a shell with your phone, then you can type those commands. I mean, I didn't need root for this.

Maybe he had some other reasons he wanted to root for as well.
Or he simply just didn't know you could do that with adb and thought rooting would be the best option with his current library of knowledge?

Link to comment
Share on other sites

On 8/30/2018 at 4:18 AM, Dave-ee Jones said:

172.16.42.1 isn't on the internet side, though.

What you're saying is it blocks all network access if it can't ping Google, which isn't true. I can access my local NAS when I don't have internet access on my Android (OnePlus 5T, latest firmware).

What's this "Management AP" you're talking about? Is it the Pineapple or something else?

Well, this is a Google Pixel thread. ...and Managment AP is WiFi Pineapple's management access point. So you can connect your Android phone to it without using WiFi Pineapple Connector app. It uses 172.16.42.1 address strictly.

On 8/30/2018 at 4:18 AM, Dave-ee Jones said:

Also, if you've got no internet on your WLAN side then wouldn't it fall back to mobile data?

You literally quoted me saying "Disabling the Mobile Data, Google can't ping and see whether the response differs, it then allows network traffic.

On 8/30/2018 at 4:18 AM, Dave-ee Jones said:

Maybe he had some other reasons he wanted to root for as well.
Or he simply just didn't know you could do that with adb and thought rooting would be the best option with his current library of knowledge?

...and where is the problem of me saying that he could have not rooted the phone? Plus, if you look to my given Stack Overflow link the answer specifically said that you can use "adb shell".

Link to comment
Share on other sites

On 8/31/2018 at 4:23 PM, moliata said:

You literally quoted me saying "Disabling the Mobile Data, Google can't ping and see whether the response differs, it then allows network traffic.

I'm very confused..

You cannot access the local network when mobile data is on because it obviously is on a different network.

Think of mobile data like a massive WiFi network spread throughout a country by big towers. It's its own network. You, therefore, cannot access another network that's not connected to that network. Your management AP is included in that. If you connect, via WiFi, to your management AP you can then access it's network - provided your mobile data doesn't take precedence as the primary network.

Some Android devices do that, especially if the Android detects that there's no internet connection over the WiFi network.

I don't know why I have to tell you this when you already have it working.

Link to comment
Share on other sites

Okay, it seems you have no idea what I mean. I'll try to explain in more simpler words for you. When you have both WiFi and Mobile data enabled and then you connect to the WiFi Pineapple management AP, you are not able to access 172.16.42.1. If you disable mobile data, you then are able to open it. I hope you get it now.

Edited by moliata
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...