Jump to content

Packet Squirrel Switch3 openVPN Client Tunnel


MarkE
 Share

Recommended Posts

Hi - I cant get get my vpn to work.......

 

I have an account with strong VPN, and down loaded the config file from there website. Copied it over to the pocket squirrel, edited the file to add user name and password, as recommended  by Strong VPN, unplugged the power, switch to position three, get yellow light flashing but my ip address never changes to the VPN address?

I simplified the payload; DNS server is strong VPN DNS ( they recommended it).

#!/bin/bash
# OpenVPN payload

DNS_SERVER="216.131.95.20"

# Cheap hack to set the DNS server
function setdns() {
        while true
        do
                [[ ! $(grep -q "$DNS_SERVER" /tmp/resolv.conf) ]] && {
                        echo -e "search lan\nnameserver $DNS_SERVER" > /tmp/resolv.conf
                }
                sleep 5
        done
}

function start() {
        LED SETUP

        /usr/bin/NETMODE VPN

        sleep 3

        # Start the OpenVPN server in the background
        /etc/init.d/openvpn start

        # Start SSH Server
        /etc/init.d/sshd start &

        # Set DNS server
        setdns &

        LED ATTACK
}

# Start the payload
start &
 

 

 

 

 

 

Link to comment
Share on other sites

You don't need to say "/usr/bin/NETMODE VPN", just say "NETMODE VPN".

I don't think it's wise to use their DNS server. Just use the Google one (8.8.8.8). They are, of course, going to recommend their own server but that's just a selling point.

You haven't configured your OpenVPN client to use the OpenVPN config file. Refer to line 45-46 in the OpenVPN payload example here.

Link to comment
Share on other sites

Thanks Dave-ee

I originally used google (8.8.8.8), but changed it as they recomended it - I don't think this is the issue as it doesn't work with either.

the default switch3 example shipping with 1.0 did not have lines 45-46 BTW

I used the file from github you recommended 'as is' with FOR_CLIENTS set to 1.

Still no luck? 

Any ideas?

 

 

Link to comment
Share on other sites

If you look at the file system format for that payload on the Github (here), does it look similar to yours? The config.ovpn file should be right next to the payload.sh file.

I think that your PS isn't connecting to your VPN, so therefore not getting it's IP. You may need to generate the .ovpn file again and retry..

I'm planning on building my own VPN server soon so I'll keep an eye out for similar troubles.

Link to comment
Share on other sites

The link didn't have a .ovpn file?

I downloaded a fresh version - its of the format;

Where auth.txt is a required password file

auth md5
auth-user-pass auth.txt
cipher AES-256-CBC
client
comp-lzo adaptive
dev tun
explicit-exit-notify 2
fragment 1390
hand-window 30
key-direction 1
mssfix
mute 3
mute-replay-warnings.................................

Flashing yellow light and "whats my ip" hasn't changed :(

Is there a verbose mode log I could look at?

 

Link to comment
Share on other sites

I am having a similar problem. I've tried setting up the VPN tunnel several times and my IP wasn't changing. I gave up and tried the basic 'everything is done for you' setup in the documentation. 

Everything went as it should with a yellow LED flashing at the end. And still my IP hasn't changed. What gives?

Link to comment
Share on other sites

Maybe this will help.

Ripped from the Packet Squirrel documentation page (emphasis is mine):

Quote

 

Deployment

With the OpenVPN server ready and the client on the Packet Squirrel configured, flip the selector switch to position 3 and deploy inline between a target and network in the same manner as the previous Packet Capture and DNS Spoof examples. When the OpenVPN connection is established the Packet Squirrel will blink yellow.

If you’re using the Client Tunneling mode there’s no further configuration necessary. To test the connection, for example if the target is a computer, try browsing to one of the many IP address testing sites like ipchicken.com to verify that the connection is being tunneled through the VPN.

If you’re using the Remote Access mode, the Internet connection of the target will not go through the VPN. Rather, the VPN may be used to SSH into the Packet Squirrel. To do so, begin by connecting to the VPN server via SSH and determine the IP address of the Packet Squirrel on its OpenVPN network. Typically this is the incremented one following the IP address of the OpenVPN servers tunnel interface. For example, on the OpenVPN server issue ifconfig and look for a tun0 interface. The default address is 10.8.0.1. From there, SSH into the Packet Squirrel as root at 10.8.0.2.

 

 

Edited by Dave-ee Jones
  • Like 1
Link to comment
Share on other sites

Still no luck for me.

Location of all files in the same directory.

Re down-loaded ovpn file.

removed the conditional out of example file so it only runs NETMODE VPN.

No IP change. - no tunnel

Will try an openVPN client on a RPi next see if its an issue with the service.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...