Jump to content
Hak5 Forums
fercato

No infusions available at Pineapple Bar

Recommended Posts

Hello forum.

I'm having troubles with my Pineapple Mark V. Actually there is no infusions available in the Pineapple Bar. I have checked and the pineapple has internet connection. However, in the network tag when I click on Show IP, no text is displayed. I need to install a new infusion because I'm in the middle of a wireless pentest. I know that the pineapple try to contact cloud.pineapple.com in order to get the infusion list. Is it possible that the cloud server is down and that's why is not working?

Here is an screenshot:

https://imgur.com/Hyi7abe

And here is what it happens after clicking show in the Network tab.

https://imgur.com/fQ8HgLM

Again, I have performed a research and I found that in the past this already happened.

Anyone has any solution?

Thank you very much, I really appreciate your help.

Share this post


Link to post
Share on other sites

Hello all,

I have the same issue. No Internet IP address or infusions available in the bar. Is there any solution for this issue?

Thank you very much

Regards

Share this post


Link to post
Share on other sites

Hello all. 

The problem still persists and I in the middle of a wireless pentest. Anyone has a solution? Or at least, is it possible to install infusions by hand, without using the GUI?

Thank you very much.

Regards.

Share this post


Link to post
Share on other sites

Hello,

I think I found a solution. In summary:

1. I installed the Firmware 3.0 Beta.

2. Connected MarkV to internet network (a wifi with internet connection) but still an error connection was presented on the screen.

3. Went to network settings and set the default route through the wifi interface (where I connected the pineapple to internet) in my case wlan1.

4. Refresh and update DNS in the network settings.

Then I was able to list and install infusions. I think, the solution has to be with the DNS update. That worked for me. Nevertheless, If you have an old firmware you may check DNS and default gateway, I don't remember whether firmwares 2.3/2.4 have this feature.

Hope this works

Regards.

 

Share this post


Link to post
Share on other sites

Hello. Thank you very much for your answer. In my case I have installed firmware 2.4. I’m not interested in updating to 3.0 since is in beta. 

Regarding the bug, I have the default route set to wan1 as you, but how did you refresh and update the dns settings? I mean, did you changed DNS configuration using SSH?

Thank you

Share this post


Link to post
Share on other sites

Hello,

I finally solved it. I tested it many times and it worked for me.

1. Set default route manually. In my case the internet connection was on wlan1. I update the routing table by setting the default route to be my router ip address (192.168.0.1). The MKV could reach it on wlan1. I did it on the web interface. See attached image1.

2. Reset DNS. In Firmware 3 you can do it in the web interface. Don't know in 2.4.  See attached image2.

3. List of infusions ok. See image3. Just try to find the way to replicate from Fw3 to Fw2.4

The good news: there is nothing wrong with the repository. The problem was routing for me. Hope it works for you too.

Images:

https://imgur.com/OABbQPI
https://imgur.com/qY4bw7H
https://imgur.com/NcuuYvy

Regards

Share this post


Link to post
Share on other sites

Sorry about that - we moved the website behind cloudflare and the mk5 firmware is too old to support its tls connection. 

I have reverted the change for now, but I can't speak for the future. 

Share this post


Link to post
Share on other sites

Thank you,

Would you please let us know where can we download the latest firmware for Mark V? I only see the 2.4 in website and 3 in forum from 1 year ago.

Regards

Share this post


Link to post
Share on other sites
6 hours ago, Sebkinne said:

Sorry about that - we moved the website behind cloudflare and the mk5 firmware is too old to support its tls connection. 

I have reverted the change for now, but I can't speak for the future. 

Hello and thank you for the information. I really appreciate that you reverted the configuration. However, I want to as why are going to leave supporting firmware 2.4. As far as I know, firmware 2.4 is the latest stable firmware for the Mark V. Firmware 3.0 is still in beta version and according to people from the forum it has many bugs with the mark V and some infusions. So, why is that? I used pineapple for professional work and And in my case the tetra is not the best option, so I want to continue with the mark V. And if you are not going to support the mark V any longer, can I just download the infusions and installed by hand? Is that possible? O can I modify the DNS to your new URL?

 

thank you very much.

Share this post


Link to post
Share on other sites
1 hour ago, Foxtrot said:

@Chewby 2.4.0 is the latest stable release firmware for the Mark V.

Exactly. You are right. I don’t understand why are they removing all the infusions. I want to know if there is any option to installed the infusions by hand, so we can backup that and used them when necessary. 

I hope Sebkinne can give us a solution for the future.

thank you for your help. I really appreciate it.

Share this post


Link to post
Share on other sites
2 hours ago, fercato said:

Exactly. You are right. I don’t understand why are they removing all the infusions. I want to know if there is any option to installed the infusions by hand, so we can backup that and used them when necessary. 

I am unsure on what you mean. We haven’t removed any of the Mark V infusions, they were unreachable from the Mark V as a side effect of moving our services behind CloudFlare.

Share this post


Link to post
Share on other sites
19 minutes ago, Foxtrot said:

I am unsure on what you mean. We haven’t removed any of the Mark V infusions, they were unreachable from the Mark V as a side effect of moving our services behind CloudFlare.

Ok. I mean that, that you moved the service.

But Sebkinne said this:

10 hours ago, Sebkinne said:

Sorry about that - we moved the website behind cloudflare and the mk5 firmware is too old to support its tls connection. 

I have reverted the change for now, but I can't speak for the future. 

"I can't speak for the future". 

So that's why I'm asking if there is any way of changing DNS or whatever it takes to point to your services in case you move them again.

Thank you.

Regards.

Share this post


Link to post
Share on other sites

Hi guys,

Let me start by saying that the WiFi Pineapple MKV has been end-of-life since late 2015. As such, it has not received any firmware updates (apart from a 3.0 preview).

The issue mentioned in this thread was caused by us switching to an infrastructure that disables some older and less secure cipher suites. Unfortunately the WiFi Pineapple MKV requires the older cipher suites, so it failed to connect.

We will try to keep the MKV functioning as long as possible. That said, we do not want to hold back our infrastructure because of an old and no longer supported device.

 

Edit: It may be possible to get support for more modern security onto the MKV, but I haven't looked into it.

  • Like 1

Share this post


Link to post
Share on other sites
On 11/13/2017 at 5:49 PM, Sebkinne said:

 

Edit: It may be possible to get support for more modern security onto the MKV, but I haven't looked into it.

 

Any updates on TLS support for MK5 Pineapple? I dug mine out and was trying to get it going again and would love to grab some infusions or a way to load them offline if not. Thanks in advance

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×