Jump to content

Serious Problem with Packet Squirrel


Recommended Posts

Hello Hak5 Forum, Long time lurker, noob sign-up here.

I received my PS a few days ago and everything was working smoothly! I did upgrade to the latest 1.1 firmware and was able to capture packets in switch1 with no problems. I then watched Hak5’s “Packet Squirrel Remote Access and OpenVPN Client Tunneling!” show and mirrored Darren’s setup. As soon as my setup was completed, I unplugged my PS and switched from “Arming” mode to Switch3 and plugged it back in, and it never booted up.

I have move the slider switch to all positions just to see if the PS will respond, nothing. I even tried moving the switch back to “Arming” mode and reflashing the firmware to 1.1 with an NTFS formatted thumbdrive. Nothing, it won’t even power up.

Is it bricked? I’m using a standard USB to micro USB for power that is plugged directly into my laptop.

I appreciate any suggestions.

Link to comment
Share on other sites

There is a recovery mode. Think its hold button for 4 sec while powering up, then browse to a 192.168.x.x address. Can’t remember where info for this is. But I had a similar issue and I managed to recover my packet squirrel.

Link to comment
Share on other sites

Hey guys,

It's still dead, no heartbeat what so ever. First I tried the firmware recovery as suggested by barry99705 https://www.hak5.org/gear/packet-squirrel/docs. I held the button for 3-4 seconds while applying power in arming mode, there was no flashing or no boot up indication. The only slight indicator of life this PS has is one very quick green flash, that's it, nothing more.

I think it may be a power issue with the PS? I've tried several power options (different cords, power packs, USB adapters to the wall, etc.) and same results. Ugh, I really like this thing and want it to work.

I do appreciate all your suggestions and assistance.

Link to comment
Share on other sites

Yeah, I've tried everything, over and over again (insanity right). I set the IP of my machine to, PS was in arming mode, and held the button for at least five seconds while plugging in, nothing. It seems it is not getting power.

I don't know what else to do. Hmmm...

Link to comment
Share on other sites

I don't have an NTFS USB in the USB slot of the PS. Only the Ethernet and microUSB for power. I have two known good USB microUSB cords that power other devices and used those on PS. No lights on PS when used with these microUSB power cords, only a very slight quick green flash then nothing. Same thing happens when the switch is in any position.

Thank you for everyone's help : )

Link to comment
Share on other sites

St4L3y - 

TL;DR - I'm sorry - that shouldn't have happened. Please contact us, we'll send you a new one. We want to get hands on your broken one so we can do a proper autopsy.

There's no good reason for your Packet Squirrel to act that way. Everything you described up until the point that it went LED silent sounded normal. In the odd case that a file got corrupted or something that prevented it from booting normally, the recovery procedure should have gotten you back up and running. That HTTP recovery console is part of the bootloader, which is in protected memory - so under normal circumstances nothing should be able to mess with it.

That said, everything you've described thereafter indicate a more complex issue. We'll want to get it back in the lab for testing, to do proper failure analysis and see if there isn't something we can do on our end to prevent this sort of fault. 

Please head over to https://hakshop.com/contact and submit a warranty request. Include your order number, link to this thread and select Item Malfunctioning from the issues list. The Hak5 team will take care of the rest.

Again, I'm really sorry for the fault and owe you thanks for detailing your troubleshooting process here. We'll get it sorted right away


  • Like 2
Link to comment
Share on other sites

Warranty request submitted...If possible, I like to know the results of the autopsy just in case it was something I did (so I won't repeat it in the future). Also, will the replacement have the 1.1 firmware?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...