Jump to content
johnnyo1012

Pocket Squirrel work with WIFI Adapter?

Recommended Posts

2 minutes ago, b0N3z said:

@Just_a_User I have gone a different route here.  i have installed hostapd-mini and got an AP up but it wont resolve an IP address to the device connecting to it.  Didnt have anymore time to play with it yesterday.  Hopefully today I can get something more out of it.

Ahhh that may require editing /etc/config/dhcp I expect @b0N3z will try and give it ago later also.

Share this post


Link to post
Share on other sites

@Just_a_User I edited that might need to go throw it again just did a quick glance at the openwrt wiki 

Share this post


Link to post
Share on other sites

These are the steps that worked for me well: (Make sure that the PacketSquirrel connected to internet)

opkg update

opkg install hostapd

remove "option disabled 1" from  /etc/config/wireless

reboot

Inside /etc/config/network ( add "option type bridge" under "option ifname eth0")

/etc/init.d/network restart

----------------------------------------------------------------------------------------------------------------------

For Encrypted wifi, inside /etc/config/wireless replace:

config wifi-iface
	option device   radio0
	option network  lan
	option mode     ap
	option ssid     OpenWrt
	option encryption none

with:

config wifi-iface
        option device     radio0
        option network    lan
        option mode       ap
        option ssid       "your ssid name"
        option encryption psk2
        option key        "password for AP"

--------------------------------------------------------------------------------------------------------------------------------------------

Note: each time the packetsquirrel is rebooted the following steps need to be repeated:

Inside /etc/config/network ( add "option type bridge" under "option ifname eth0")

/etc/init.d/network restart

Edited by mo78
update
  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, mo78 said:

These are the steps that worked for me well: (Make sure that the PacketSquirrel connected to internet)

opkg update

opkg install hostapd

remove "option disabled 1" from  /etc/config/wireless

reboot

Inside /etc/config/network ( add "option type bridge" under "option ifname eth0")

/etc/init.d/network restart

thanks for sharing :) Confirmed it throws up an open AP and gives internet access to clients, Just need to check if it breaks anything and try getting encryption working if possible.  Would be great is we can get client mode with encryption also.

Edited by Just_a_User
  • Like 1

Share this post


Link to post
Share on other sites
29 minutes ago, mo78 said:

config wifi-iface
        option device     radio0
        option network  lan
        option mode       ap
        option ssid       MyWifiAP
        option encryption' psk2
        option key        secret passphrase

Yeah i tried this and it didnt work for me. Did it work for you?

I think were missing wpa_supplicant or something?

Share this post


Link to post
Share on other sites

it worked for me fine. Just wants to remind you that every time you reboot your packetsquirrel, you have to do these steps again:

inside /etc/config/network ( add "option type bridge" under "option ifname eth0")

/etc/init.d/network restart

Since we can't change the rom configuration in /rom/etc/config/network. the changes will not be permanent. so if you first configure the /etc/config/wireless with these:

config wifi-iface
        option device     radio0
        option network    lan
        option mode       ap
        option ssid       "your ssid name"
        option encryption psk2
        option key        "your password"

Then add "option type bridge" and restart network services, you should be fine.

Share this post


Link to post
Share on other sites
43 minutes ago, mo78 said:

it worked for me fine. Just wants to remind you that every time you reboot your packetsquirrel, you have to do these steps again:

inside /etc/config/network ( add "option type bridge" under "option ifname eth0")

/etc/init.d/network restart

Since we can't change the rom configuration in /rom/etc/config/network. the changes will not be permanent. so if you first configure the /etc/config/wireless with these:


config wifi-iface
        option device     radio0
        option network    lan
        option mode       ap
        option ssid       "your ssid name"
        option encryption psk2
        option key        "your password"

Then add "option type bridge" and restart network services, you should be fine.

Yep did all that, you know what it was? i counted my password and it was 7 digits not 8... working now :) I will script a config backup and restore to get around reboot.

I used hostad-mini to save a little space and that worked also. Thanks for the assist!

 

  • Like 2

Share this post


Link to post
Share on other sites
On 09/11/2017 at 5:01 PM, mo78 said:

it worked for me fine. Just wants to remind you that every time you reboot your packetsquirrel, you have to do these steps again:

inside /etc/config/network ( add "option type bridge" under "option ifname eth0")

/etc/init.d/network restart

Since we can't change the rom configuration in /rom/etc/config/network. the changes will not be permanent. so if you first configure the /etc/config/wireless with these:


config wifi-iface
        option device     radio0
        option network    lan
        option mode       ap
        option ssid       "your ssid name"
        option encryption psk2
        option key        "your password"

Then add "option type bridge" and restart network services, you should be fine.

Managed to get an AP up and running using this, but stuck on how to tunnel the wireless traffic through the openvp. So i can have the Squirrel sat on to my router and then could connect to either the wifi AP or the WIfi VPN AP. ??

If that makes any sense !

Share this post


Link to post
Share on other sites
4 hours ago, ThingEngineer said:

Has anyone got it up and running yet?

I think at this stage were all at the point where you can setup an encrypted AP on the squirrel itself and via wifi have access to the squirrel and LAN/internet. I didn't get so far for client mode when joining encrypted networks, but maybe that's just me.

Edited by Just_a_User

Share this post


Link to post
Share on other sites
10 hours ago, Just_a_User said:

I think at this stage were all at the point where you can setup an encrypted AP on the squirrel itself and via wifi have access to the squirrel and LAN/internet. I didn't get so far for client mode when joining encrypted networks, but maybe that's just me.

I didnt either but there should be a better way to keep the AP even after shutdown without having to edit the /etc/config/network everytime you power up.  Editting the /rom is a no go unless somebody knows how to make it a read/write directory.

Share this post


Link to post
Share on other sites
16 hours ago, b0N3z said:

I didnt either but there should be a better way to keep the AP even after shutdown without having to edit the /etc/config/network everytime you power up.  Editting the /rom is a no go unless somebody knows how to make it a read/write directory.

There is another way to get it working without editing the /etc/config/network file. You can use NETMODE Bridge or Transparent. This should give you the same result. You can run NETMODE as one of the payload switch options. For example switch1 payload can run NETMODE Bridge.

Share this post


Link to post
Share on other sites
On 11/12/2017 at 4:49 AM, EvilMutley said:

Managed to get an AP up and running using this, but stuck on how to tunnel the wireless traffic through the openvp. So i can have the Squirrel sat on to my router and then could connect to either the wifi AP or the WIfi VPN AP. ??

If that makes any sense !

I might not be understanding what exactly you are trying to accomplish. The wifi AP subnet is the same as the LAN subnet. Since this set up as bridged mode, IPs for wifi clients are acquired from LAN. Routing the traffic from WIFI is also treated the same as routing the traffic from LAN interface. I am also confused with the term wifi vpn AP? What do you mean by this ?

Edited by mo78
Correct mistakes

Share this post


Link to post
Share on other sites

By having the squirrel acting as a seperate WiFi access point, to my WiFi router are we able to connect to it and route the wireless traffic through the openVpn  

Share this post


Link to post
Share on other sites
2 hours ago, EvilMutley said:

By having the squirrel acting as a seperate WiFi access point, to my WiFi router are we able to connect to it and route the wireless traffic through the openVpn  

This maybe possible but you have to change where does the packetsquirrel wifi get it's ip address from. Currently, it's getting it from lan interface. When you check the /etc/config/wirelsess, you will see that the option for the interface is lan. I think that option Will need to be changed to wan. There might be other settings need to be tweaked. I haven't tried it myself and currently traveling for work. I Will try to check it out over the weekend.

Share this post


Link to post
Share on other sites

Can anyone suggest a compatible usb wifi adapter?  I have tried the two that i have and i am unable to get a wlan0 interface.  

 

BusyBox v1.23.2 (2017-09-06 11:27:56 UTC) built-in shell (ash)
 

root@squirrel:~# uname -a
Linux squirrel 3.18.45 #13 Mon Oct 30 21:24:27 UTC 2017 mips GNU/Linux
 

Dmesg of me unplugging and pluggin it in:

[  210.890000] usb 1-1: USB disconnect, device number 5
[  214.350000] usb 1-1: new high-speed USB device number 6 using ehci-platform
 

lsusb output:

Bus 001 Device 006: ID 0bda:8176
Bus 001 Device 001: ID 1d6b:0002
 

The usb adapter i am trying to use is: https://www.walmart.com/ip/Edimax-Network-EW-7811UN-Wi-Fi-N-150M-2-0-Mini-Nano-Wi-Fi-Adapter-NEW/17419471?wmlspartner=wlpa&selectedSellerId=13209&adid=22222222227014437374&wl0=&wl1=g&wl2=c&wl3=40882078712&wl4=pla-78811760912&wl5=9022096&wl6=&wl7=&wl8=&wl9=pla&wl10=118771572&wl11=online&wl12=17419471&wl13=&veh=sem

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...