Jump to content

SSH using private key?


Recommended Posts

I'm probably doing something wrong or missing a step (although I was sure I triple checked!), but I cannot seem to get SSH using private/public key authentication working.

Using -vvv doesn't really yield anything helpful - it simply skips that method of authentication and asks for a password.

I've checked permissions, looked over sshd_config, tried generating on both the Squirrel and my PC, and nothing seems to do the trick. I'm at my wits end, so I came here in hopes that someone has had success getting this to work.

Link to comment
Share on other sites

That was a great suggestion, but even after generating the key and having it successfully copy over using ssh-copy-id (once I ssh into the Squirrel I can see the pub key has been copied into the auth file), it still prompts me for the password, even when I use -i :sad:

If need be I can post the verbose output.

Link to comment
Share on other sites

On 10/30/2017 at 3:54 AM, _TheHobbyist_ said:

I managed to get it working. Since I am SSHing in as root, I needed to disable write and exec permissions on the root folder. Once I did that it used key authentication. Hope this helps others that might have the same issue.

That's on;y needed for the keys stored in the /root/.ssh folder though. I was able to take a Squirrel out of the box, use ssh-copy-id to copy my keys, and SSH in without changing any permissions.


10 hours ago, LGee said:

Oh I thought this was about a different topic. But is there a way to setup reverse SSH towards a cloud IP to get in, instead of using VPN?

Currently you can use AutoSSH, but we are replacing that with SSHTunnel in firmware 1.1.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...