Jump to content

Creating new language layout, special character issues


Recommended Posts

I want to create a couple of new keyboard layouts for the community. I downloaded USBlyzer, so that I could observe the key codes for all the keys on my keyboard. On Czech keyboard, some special characters need "special attention". For example, pipe character is not present, unless I press "leftCtrl+leftAlt+w". Once I do that, I can see the code in USBlyzer:

05 00 1a 00 00 00 00 00

So far so good. I went to /languages/us.json, made a copy, named it cz.json, and changed pipe line accordingly:


Then I created this simple payload.txt to see if it is pressed (I have Czech layout turned on)


When I tried this, I can only see "blaaa" string being shown, no pipe character is present. Note that when I change DUCK_LANG to "us" it works and writes pipe character as expected.

Am I missing something, or Bash Bunny has some issues with running these commands?

Link to comment
Share on other sites

On 21/10/2017 at 12:31 PM, hipapheralkus said:


Did you actually put the inverted slash?

Maybe is because you haven't mapped yet the inverted slash...

you just should type 



I also have got some troubles but with the characters


only those and I don't know why

Link to comment
Share on other sites

  • 2 weeks later...

Thanks a lot:) It seems that I made 2 or 3 mistakes:

  • when typing payload.txt, I should have used double-quotes, e.g.
    QUACK STRING "My super \"payload\" | everything works"

    As stated in the us.json file, the only 2 characters requiring escaping are backslash and double-quote, as long as I write everything into double quotes

  • it seems that changes in .json files are not properly taken, until I safely remove my Bunny USB, which caused me plenty of trial-and-error why it doesn't work

  • and final change was moving 


    a bit more upwards, so that all keys using CTRL+ALT are properly (not sure if this step was necessary though)

I've just created Pull request from Czech and Slovak json language files, and they work for me on machines I tried:)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...