Jump to content
Hak5 Forums
jimmy1_1

Cannot Download or Start Modules

Recommended Posts

Hello everyone,

I am having an issue which I have found has struck other users(links below) but I have not found a satisfactory resolution. Here are all of my previous efforts:

- Download and install modules with curl (link)  Modules install but do not work properly; for example, urlsnarf makes empty logs, despite me simulating online activity. Start page says, "warning: commands will be executed using /bin/sh job (number) at (date)

urlsnarf started with pid (number)

- "opkg update" and "opkg list-upgradable" none were upgradable

- "firstboot && reboot" absolutely no change in regards to these issues

I hope someone has some answers or can point me in the right direction, because I am pretty sad about this. Thanks for your time

Share this post


Link to post
Share on other sites
7 hours ago, jimmy1_1 said:

I hope someone has some answers or can point me in the right direction, because I am pretty sad about this. Thanks for your time

Did you already get the lanturtle online and run all OS and module updates from the turtle interface?

Or if not working maybe try a manual OS/firmware reflash like here: -

Once you know the OS/firmware is 100% latest then repeat your update of all the modules using the lanturtle interface or manually.  Hopefully the issues go away after that.

Edited by Just_a_User
  • Upvote 1

Share this post


Link to post
Share on other sites

Thank you for your response! When I got it and attempted to update from the module, it simply said there were no updates available. I have not tried your other suggestions, and will promptly do so. 

Share this post


Link to post
Share on other sites

I still ran into the exact same problems after doing the above process. Cannot install modules, despite being able to connect to the website. Also, I cannot start modulemanager

Share this post


Link to post
Share on other sites
13 hours ago, jimmy1_1 said:

Cannot install modules, despite being able to connect to the website. Also, I cannot start modulemanager

Maybe try what this guy did, seems he had similar issue: -

Or just try with reinstalling module manager first: -

opkg update

opkg install curl

curl https://raw.githubusercontent.com/hak5/lanturtle-wiki/gh-pages/modules/modulemanager -k -o modulemanager

chmod +x modulemanager

 

Edited by Just_a_User
  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×