Jump to content
AGD

Windows Internet Connection Sharing

Recommended Posts

I have been running BB for months now and sharing the internet connection on a Windows pc was no hassle at all until today.

Now , when I try to give the ip 172.16.64.64  to the RNDIS adapter, after confirming with OK, the IP adress changes to a local network adress (192.168.137.1 - dunno where this suddenly comes from)

Can't ping and apt-get from the Bunny anymore.
 

Share this post


Link to post
Share on other sites

Have you recently changed other connections, like your WiFi or home ethernet or something along those lines? Have you joined another network?

Share this post


Link to post
Share on other sites
11 hours ago, Dave-ee Jones said:

Have you recently changed other connections, like your WiFi or home ethernet or something along those lines? Have you joined another network?

Yes. I changed the wifi, but I do this once in a while depending on connection speed. The only way out is, when I change the tcp4 ip I only confirm the first window and let the second window open, because at that time the right ip 172.16.16.64 still works, but as soon as I confirm the second window, the other 192 ip shows up and the Bunny has no more internet.

Share this post


Link to post
Share on other sites

Could you send a screenshot of the first and second window? I want to know what they are, because I'm not sure where you're getting them from..

It sounds like your configuring the wrong adapter, but I can't be sure.

Share this post


Link to post
Share on other sites

I opened ncpa.cpl, righ mouse on the Bunny Ethernet (definitely the right one called 'ethernet'), Properties, when I click on TCP4 it opens the second window (Properties of TCP4). I put in the correct IP (172.16.16.64/255.255.255.0) and I click on "OK". Second window closes and the first window (Properties of Ethernet) is still open. At this point the internet sharing works. If I then click OK on the Window (Properties of Ethernet) the (bad) IP 192 seems to automatically come back.

Share this post


Link to post
Share on other sites
On 9/15/2017 at 10:15 AM, AGD said:

Now , when I try to give the ip 172.16.64.64  to the RNDIS adapter, after confirming with OK, the IP adress changes to a local network adress (192.168.137.1 - dunno where this suddenly comes from)

Hey there.I am having the same issue as you are. Only difference is that i never had the luxury of getting mine to actually ever share an internet connection. In any event, what you are seeing is a VMware ip address for a vmware eth. I get the same thing when i remove the RNDIS usb from my device manager and then add it again. After I fight with the errors about 2-3 times it usually switches to what i am trying to put in. I have been using 172.16.64.64, however i see you are using 172.16.16.64??? Is this for real or have you set it up this way? It certainly isn't the default ip that has been given in the different tutorials. I would love to get mine to work online and if you have any pointers PLEASSSSE send them my way. Thanks man

setup.PNG

Share this post


Link to post
Share on other sites

now i am getting the same exact message that you did and i cant stop it. No internet sharing. Eyes are borderline bloody by now.

 

 

ics.PNG

Share this post


Link to post
Share on other sites

I used the IP of my first posting. The second one was an error. I have no idea how to fix that issue.

Share this post


Link to post
Share on other sites
3 hours ago, AGD said:

I used the IP of my first posting. The second one was an error. I have no idea how to fix that issue.

The only thing that works for me properly is to reset my network adapters, restart the computer and renter the addresses and initiate ICS again. Works every time but I have to do the dam reset often. Plus I can’t  have RNDIS adapter for serial ICS enabled as this messes up the configuration since they are 2 different types of adapters. I wish it was like Alan Turtle where it would automatically receive its IP address and all that need be done is share from wlan. Oh well. All the best

Share this post


Link to post
Share on other sites

There is a payload for Windows that does this all for you called "Windows NIC Sharing". Should be in your payload library under General. :)

Hope that helps a lil.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...