Jump to content
srborines

WiFi Client Mode doesn't work with WEP protocol (Solved)

Recommended Posts

In the section Networking of the pineapple application is possible connect the interface wlan1 to a wifi but this method only works with WPA encryption, using WEP protocol simply doesn't connect.

This happens because the api of the module 'networking' (/pineapple/modules/Networking/api/module.php), in the function connectToAP(), is only designed to modify the wireless configuration file (/etc/config/wireless) in the case that the encryption be open or differents types of WPA.

This is not exactly a bug, simply the function wasn't designed to all cases but I think that is really interesting at least have the WEP protocol because is unusual but unfortunately is used and is a weakness that in a pentest can be used to provide internet to our device.

To fix this issue I modified the file '/pineapple/modules/Networking/api/module.php' adding to the switch the case of WEP protocol, because it's neccessary modify the variable of configuration 'encrypt', in this case is ' web', and the key should be the hexdump of the string. The changes done can see it in the next images: pineapplebug1.png 

pineapplebug2.pngs

I hope that this helps you!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...