Jump to content

This just isn't working (OSX running Parrot OS in VirtualBox)


Recommended Posts

Hi,

Yes, before you get your pitchforks out, I have read and followed all the different versions of instruction on getting this to work. So the setup I have is OSX Sierra running a Parrot OS distro in VirtualBox.

ICS is up and running (I think).

Installed the driver that is posted on the forums here.

Tried that future proof ICS settings where you change the IP after SSH-ing into the Nano.

I have tried everything and I can NOT get the Nano to load modules or bulletins or anything.

When I run the w6 script in Linux, it just completely blocks my access to the Nano Dashboard saying the browser can not connect. 

Any help would be much appreciated.

See relevant screens here --> http://imgur.com/a/lXQPR

I also followed this guide with no luck --> http://j2abro.blogspot.com.co/2016/07/configuring-wifi-pineapple-nano-on-mac.html

Edited by dikdronk
Link to post
Share on other sites

If your going to use your pineapple on a Parrot VM you dont need to use the all the OSX stuff to connect it.  I suggest hard restarting your nano and go through the setup on mac without ICS and when its setup start your Parrot VM and on the bottom bar of Virtualbox you will select the usb devices and make sure you have the nano going to the VM and not mac.  Then run the wp6.sh with the manual setup.  make sure you know your Gateway IP from your router and that should be all you need to do.

Link to post
Share on other sites

Thanks for the reply @b0N3z, I did the steps you recommended, but no dice. When running the wp6 script it doesn't detect the pineapple in the final step. Am I supposed to connect to the pineapple for wifi, or to my normal wifi?

Yes, these are dumb questions, sorry.

Link to post
Share on other sites

connect the pineapple via usb y cable and depending on your pc you might need to use an external battery to power all the way.  that will show up as an asix 88178 and youll connect that to the vm your using and then it should show and you can run the script

 

Link to post
Share on other sites
  • 9 months later...
  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...