Jump to content

This just isn't working (OSX running Parrot OS in VirtualBox)


Recommended Posts


Yes, before you get your pitchforks out, I have read and followed all the different versions of instruction on getting this to work. So the setup I have is OSX Sierra running a Parrot OS distro in VirtualBox.

ICS is up and running (I think).

Installed the driver that is posted on the forums here.

Tried that future proof ICS settings where you change the IP after SSH-ing into the Nano.

I have tried everything and I can NOT get the Nano to load modules or bulletins or anything.

When I run the w6 script in Linux, it just completely blocks my access to the Nano Dashboard saying the browser can not connect. 

Any help would be much appreciated.

See relevant screens here --> http://imgur.com/a/lXQPR

I also followed this guide with no luck --> http://j2abro.blogspot.com.co/2016/07/configuring-wifi-pineapple-nano-on-mac.html

Link to comment
Share on other sites

If your going to use your pineapple on a Parrot VM you dont need to use the all the OSX stuff to connect it.  I suggest hard restarting your nano and go through the setup on mac without ICS and when its setup start your Parrot VM and on the bottom bar of Virtualbox you will select the usb devices and make sure you have the nano going to the VM and not mac.  Then run the wp6.sh with the manual setup.  make sure you know your Gateway IP from your router and that should be all you need to do.

Link to comment
Share on other sites

Thanks for the reply @b0N3z, I did the steps you recommended, but no dice. When running the wp6 script it doesn't detect the pineapple in the final step. Am I supposed to connect to the pineapple for wifi, or to my normal wifi?

Yes, these are dumb questions, sorry.

Link to comment
Share on other sites

connect the pineapple via usb y cable and depending on your pc you might need to use an external battery to power all the way.  that will show up as an asix 88178 and youll connect that to the vm your using and then it should show and you can run the script


Link to comment
Share on other sites

  • 9 months later...
  • 2 years later...


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...