Jump to content

Linux Kernel 4.11, reaver and bully (WPS)...Issues?


Recommended Posts

So, I use ParrotOS.  A week ago it updated from 3.6 to 3.7 moving the kernel from I believe was 4.4 to 4.11.

Okay, after that happen, all wps attack I can do no longer work.  Wash works but reaver and bully does not, at all.  Issue is posted on t6x repository for reaver.  A few of the contributors have responded to a few people having the same issue going to the new version of Kali.  Issue is either association issues in reaver followed by repeated send and receives and either a deauth, timeout or looping EAPOL messages.

All my stuff running ParrotOS was already on 3.7 and had the same issue except for 1 device I still have on 3.6 and Kernel version 4.4.9.  Reaver works fine on it with my alfa with the -T 3 option. ( T 3 option was recommended by one of the contributors).

So, I am talking with the Parrot folks to see if there is a repo I can use (since I still have the 3.6 iso) that can update a 3.6 installation to the newest updates before 3.7 for testing just to see if it really broke right before or after the kernel update.  The reaver folks want to see how it responds to the other kernel versions like 4.8, 4.9 to see exactly where it goes south.  Of course he doesn't know how to do kernel compilations and I have not done that either.

What I am wondering is if others have experienced the same on their distros of linux running Kernel 4.11..if they got it?


Link to comment
Share on other sites


With a little googling, I managed to find the older versions of the ISO files if you ever need them or want to compare contents. I didn't see anything on the actual main site of theirs that linked to source files themselves: https://sourceforge.net/projects/parrotsecurity/files/iso/

Edit 2:

So in some more digging(for Kali anyway) because I'd like to know myself how to compare changes, if you look in /boot, you should see a config file which shows what it was compiled with(Debian and RedHat based ones anyway). If Parrot doesn't have it but was compiled with "CONFIG_IKCONFIG_PROC" enabled on the kernel, then a config file should/might be in /proc/config.gz 

What I would then do with the Parrot ISO's is install each fresh ISO in a VM, test the tools you mention above to make sure works as you say(or don't work as you say), and then compare the config files for each(with something like diff, or use meld in GUI to move switches from one to other), to see if anything looks like it's related to your issue, and maybe you can recompile with what switches were missing in the newer one, with what works from the older one. This is an assumption on my part, as I don't know much about kernel changes and compiling them to turn features on and off, but would be where I'd start looking for differences between them to see what might fix the issue when re-enabled or added back into the mix. I know there are some Linux gurus on the forums that would probably spot the issue or know where to look better than myself, and might also know more about recompiling the changes needed to turn the feature back on. Hopefully someone chimes in if they do.

Edited by digip
Link to comment
Share on other sites

I actually found a workaround that I used when I had kali install last year and had the same issue in reaver.  I used the -A option in reaver to have it not associate and then used aireplay for the associations.  It is now working for the time being.

I actually tried the VM way with older versions of the Parrot ISO but have a little issue.  My Win10 machine doesn't share its USB wifi very well with VirtualBox.  I have the device busy issue with it.  All the fixes I read about no workie so I am good.  On Linux I am running the kernel I am having issues with so I think that is translating to my VirtualBox VM.  When I run a version I know works, it doesn't.  If I install it to a usb stick and boot with it, it works so I think I am going to be installing versions to usb sticks to test but have a workaround in the meantime for my daily machine.

Link to comment
Share on other sites

Yeah, virtual box on even my Win7 system, only shows my USB wifi as eth# adapters, not wlan#, so you're not alone there. I use VMware mainly because Virtual box is such a shit. Vbox is what I use for Vulnhub CTF's since that is what most of them were made with, and my version fo WorkStation can't open some of the newer VM's, but my main Kali box, is VMware based and uses my USB wifi cards with no issues. If you want, try VMware player, which is free, but only one instance will run at a time vs Woirkstation, which I can run many VM's at the same time on my system with no issues.

Also, the USB booting of these that work, Kali tends to be like that too, they sometimes come with different switches enabled on the Live version's kernels, or different driver configs. native installs for whatever reason, have been known to function slightly differently, but I think this is more package update related stuff once installed. I just figured since you said it was after updating to a newer kernel version, doing a compare of the configs might show what switches were either baked in(=y), added as modules(=m) or just removed all together, either by not being there or commented out with a # or =n. diff is always a PITA(in my opinion), but meld is nice in that you can scroll and see side by side the two configs, where things were changed and line by line what might be the culprit. Especially since all the comments for each section are easily visible, which helps when scrolling through the wireless driver section.

Edited by digip
Link to comment
Share on other sites

If i understood the OP correctly; you believe the kernel-change might have been the cause of your problems with Reaver.


 If it was me i would simply try to compile different kernel-versions myself, to see if it fixes the issue.
Usually you can find the .config file for your current kernel within the /boot directory. (At least on Kali/ Debian)
You can then copy this .config file to whatever custom kernel you are trying to build, to make it compile with the same settings, or to perhaps look at the differences.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...