Jump to content

Storage Mounting Issues


Recommended Posts

I am experiencing an issue with mounting the storage (/root/udisk).

Anytime I run "mount -o sync /dev/nandf /root/udisk", the Bunny mounts udisk correctly, but does not stay mounted.  Every time I reload the Bunny, udisk is not mounted.  I even wrote a shell script that automatically runs this command at startup (I tried all three in the highest rates response and crontab to no avail), and udisk does not mount.  It has been included in /usr/bin so that I can run it without having to navigate to that specific directory with the .sh file, and that works too.  I tried running this script as part of a Bunny payload, and it still will not mount as part of a payload either.  I can only get udisk to mount by SSH or a Serial Connection to the Bunny.  I am using the latest version.  The kernel version from "uname -r" is 3.4.39 if anyone needs to know that.

Any ideas on what is going on?

If you need any more information, let me know.

Thanks in advance,


Link to comment
Share on other sites

You are correct, the udisk is unmounted everytime the Bunny turns off. Everytime it starts up you need to mount it again. I would presume this is so the ATTACKMODE module works correctly, making sure the STORAGE mode isn't automatically setup every time the Bunny boots. Sebkinne talked about this somewhere but I can't remember where (otherwise I would link it).

Use arming mode or a payload with ATTACKMODE STORAGE in it to access storage correctly.

Also try the commands "udisk reformat" or "udisk mount". 'udisk' is an inbuilt alias Sebkinne made so that you can do what you are explaining easily and with more success.

Link to comment
Share on other sites

Thank you for your reply.

I tried "udisk mount" in the shell and it works just fine, but still will not work in a payload.

Below is my exact payload I am attempting to run on switch 2.


sleep 2


udisk mount

sleep 2

if [ ! -d /root/udisk/checkmount]; then
	echo "Error mounting udisk" > /var/myscripts/er.log

Note: /root/udisk/checkmount is a test directory I made just to check for existence, implying udisk mounted correctly.

The light also turns red right after yellow instead of finishing the rest of the script, which would end on magenta.  Is my syntax wrong?  I am new to bash/shell scripting.

Thank you for your time,


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...