Jump to content

How can I stop both Wi-Fi interfaces from connecting to my home hub?


haze1434
 Share

Recommended Posts

Hi all,

I was playing with hoover.pl last night, which works great, apart from when it gets to line 108;

(system("$iwconfigPath $interface mode monitor")) && die "Cannot set interface $interface in monitoring mode!\n";

It returns the above die error, with the reason given being;

Error for wireless request "Set Mode" (8B06) :
	SET failed on device wlan1 ; Device or resource busy.

 

I am using a RPi3 with an Alfa Wi-Fi card connected to one USB port. The internal Wi-Fi chip is wlan0 and the external Alfa card is wlan1.

I have the internal chip wlan0 connected to my home Wi-Fi, as intended, so that I can SSH to the RPi.

However, I believe the issue above is stemming from the fact that, when I run iwconfig, both wlan0 and wlan1 are showing as being connected to my home Wi-Fi.

I don't want this; I would like wlan0 to connect to my home Wi-Fi, but wlan1 to stay available to use in monitor mode.

 

I have tried;

iwconfig wlan1 down
iwconfig wlan1 mode monitor (and/or) airmon-ng start wlan1
iwconfig wlan1 up

No luck; wlan1 still insists on reconnecting to my home Wi-Fi and setting itself back to Managed mode.

 

How can I stop wlan1 (Alfa card) connecting to my home Wi-Fi, but leave wlan0 (RPi3 internal) connected to it?

 

Thank you.

Edited by haze1434
Link to comment
Share on other sites

Try "ifconfig wlan1 down" not iwconfig. Also, if you want monitor mode on wlan1, try "airmon-ng start wlan1" before using the other tool. This should fix the issue and put it in monitor mode for you.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...