Jump to content

RT3070 airodump issue


TeCHemically
 Share

Recommended Posts

I just got the RT3070 usb adapter and airodump isn't working on any OS. Tried 3 systems so far and every one of them shows all blank once the card is in mon mode and I start airodump. I ran check kill so nothing is interfering with it. What's the deal with this card? Any help is appreciated.

Link to comment
Share on other sites

Are you sure it's a compatible card? Find out what driver is loaded for it.

https://www.aircrack-ng.org/doku.php?id=compatibility_drivers

 

Post dmesg and any other out put you may have when bringing it up and starting monitor mode. That should help others get an idea what is happening. If you have network manager running, I suggest killing it before trying any monitor mode stuff.

By the way, if it's the "AWUS036NEH", that might be the one that is not compatible or have drivers, but I could be wrong. I've got a AWUS036NHA though. Mine works with monitor and injection, but can't do evil twin since it has only one antenna/input, and not mimo like some of the other cards.

 

 

Edited by digip
Link to comment
Share on other sites

16 hours ago, digip said:

Are you sure it's a compatible card? Find out what driver is loaded for it.

https://www.aircrack-ng.org/doku.php?id=compatibility_drivers

 

Post dmesg and any other out put you may have when bringing it up and starting monitor mode. That should help others get an idea what is happening. If you have network manager running, I suggest killing it before trying any monitor mode stuff.

By the way, if it's the "AWUS036NEH", that might be the one that is not compatible or have drivers, but I could be wrong. I've got a AWUS036NHA though. Mine works with monitor and injection, but can't do evil twin since it has only one antenna/input, and not mimo like some of the other cards.

 

Thanks for the reply. I did kill network manager prior to use ; and this is the card Daren is selling in the hakshop. It says it works out of the box. I'll post dmesg as sson as I can.

 

Link to comment
Share on other sites

Yeah, if you got it on the hak shop, then should be working. I know that the NEH model, is hit or miss for some people, and don't always have the actual same chipset, depending where you get them. It's one of the least fav cards by people.

http://www.wirelesshack.org/best-kali-linux-compatible-usb-adapter-dongles-2016.html

Other than the card, what is your setup and what are you monitoring? If you have a home wifi router to test with, try connecting and disconnecting from it a few times with another device while in monitor mode and wireshark is going, or airodump. Make sure to start airodump on a specific channel, not to start it without a channel selected, can skew your chances of seeing anything connect. Monitoring a single channel at a time generally gets best results.

Link to comment
Share on other sites

20 hours ago, digip said:

Yeah, if you got it on the hak shop, then should be working. I know that the NEH model, is hit or miss for some people, and don't always have the actual same chipset, depending where you get them. It's one of the least fav cards by people.

http://www.wirelesshack.org/best-kali-linux-compatible-usb-adapter-dongles-2016.html

Other than the card, what is your setup and what are you monitoring? If you have a home wifi router to test with, try connecting and disconnecting from it a few times with another device while in monitor mode and wireshark is going, or airodump. Make sure to start airodump on a specific channel, not to start it without a channel selected, can skew your chances of seeing anything connect. Monitoring a single channel at a time generally gets best results.

I got airodump results on a different laptop. Do you know if the cards in the hakshop are NEH or NHA? If this wont work on my main rig then I'm going to have to return it. Shame too. It was a great price. I hope Darren isn't carrying the crap shoot card that contains inconsistent chipsets.

Link to comment
Share on other sites

I have no clue what is in the shop, but the fact it works on one machine and not the other sounds more like the machine, not the card. Best i can say is keep testing, make sure the card is in same open proximity as the machine you tested it on that worked. If it's in a different location and not working, might be something in the room impeding signal or blocking it from seeing what the other machine could, based on where it was positioned.

Link to comment
Share on other sites

Were you ever able to resolve this? 

I just ran into a similar issue. The model wifi card I just bought, is a TP-Link TWN722N. It's rated as one of the top Atheros compatible Kali Linux cards. However, even though it IS a TWN722N card, there is a catch. Revisions. The working versions, are V1.0 cards. Mine, is a V2.1, and as such, is NOT 100% compatible with Kali. I had no idea, nor was I able to spot the revision issue since I bought this online and was not listed on Amazon what revision it was(I should have checked around before though, is my own fault). The manufacturer makes these kinds of updates, and in doing so, has more than one version of the same card out there packages with the same base name. I suspect it's possible your situation is like mine, in that you unfortunately got one of the wrong cards based on a re-visioned model, but that is my suspicion, and not 100% certain. You may have different issues than what I faced with mine, but is a hunch. Without us seeing your output, hard to say.

Few more commands you can try, "lsmod | grep usb" and see what modules are listed for USB devices. This will show us what driver is loaded for the card. Can also "lsusb" to look for the name of the card. If it's shown in lsusb, but no name against the device when plugged in(compare with and without card to know which port it is) you probably have the same problem I do, in that it's a version without the correct driver for the firmware on the card. In my case, it seems like a different chipset as well. I managed to get generic drivers loaded on mine, which let me only use it for connectivity, no injection or monitor mode available for it as of yet.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...