Jump to content
Hak5 Forums
nik321

Can't connect Lan Turtle over Wifi and now I think I broke it :(

Recommended Posts

nik321   

Hello guys.

So I have just followed this guide to set up my lan turtle over wifi so I don't need to plug it into the ethernet to set it up/update/etc

https://www.youtube.com/watch?v=11qAQ3X71X0

 

I do this on my Kali machine (So I can open up the turtle.sh file)

I follow all the steps... it works fine... I can even ping google...

But as soon as i unplug the Turtle, and plug it into my Windows PC... All that change and config gets deleted....

I cant access the turtle.sh to set it up on my windows PC either because you cant open bash scripts in powershell

And now when I RE-PLUG it back into my Kali to do all the ./turtle.sh again... It wont ping google now??? I follow the step by step, run the bash file... Set up my default gateway... And then when its all done and says "happy shelling" it no longer pings google???? 

Do I need to do a hard reset?

Share this post


Link to post
Share on other sites
nik321   

I should also mention that once I run the ./turtle.sh - And it completes.... And I try to ping google.com .... it doesnt ping (like i mentioned above) - BUT, I also cant access it on my browser... So its like i have no internet connection... Like the Lan Turtle is robbing it.

Share this post


Link to post
Share on other sites
nik321   
25 minutes ago, Lord_KamOS said:

I doubt its broken. Try a reset. 

 

So if I do a hard reset, re-install the firmware... Then from the beginning, plug it into my kali machine, run the ./turtle.sh - I should then be able to ping google and also update my turtle through wifi rather than having to plug in an ethernet?

 

Also do you have any suggestions as to why when I unplug the duck, and then plug it back in, it goes back to only being able to do ethernet? Is there a way to persistently make it run off wifi? or do i need to run that script every time?

Share this post


Link to post
Share on other sites
4 minutes ago, nik321 said:

through wifi rather than having to plug in an ethernet?

I do not have a turtle so i cant test this. BUT from what i understand, when you run the script it will share a internet connection from your computer to the turtle. So yes no need for Ethernet. But its not over wifi, you share your connection from the computer over to the turtle, doesn't matter if your computer uses wifi or cable.

7 minutes ago, nik321 said:

Also do you have any suggestions as to why when I unplug the duck, and then plug it back in, it goes back to only being able to do ethernet? Is there a way to persistently make it run off wifi? or do i need to run that script every time?

I just assume you mean the turtle. But yes you need to run the script every time because  iptables resets after reboot.

Share this post


Link to post
Share on other sites
nik321   
4 hours ago, Lord_KamOS said:

I do not have a turtle so i cant test this. BUT from what i understand, when you run the script it will share a internet connection from your computer to the turtle. So yes no need for Ethernet. But its not over wifi, you share your connection from the computer over to the turtle, doesn't matter if your computer uses wifi or cable.

I just assume you mean the turtle. But yes you need to run the script every time because  iptables resets after reboot.

I just don't understand though why when I plug the turtle in, I can no longer access the internet on my computer? Maybe this is the reason the ping part is failing? Because when I plug the turtle in, it doesnt allow me to access the internet any more?

  • Upvote 1

Share this post


Link to post
Share on other sites

when you share a connection with the turtle.

Can you access the internet from the turtle, or do both computer and turtle loose connection?

  

Share this post


Link to post
Share on other sites
dbum   

I also do not have a turtle but what sounds like is happening is when you plug the turtle in, it is seeing that as the way to the Internet (making it the default route).  Go into IPV4 settings for the Turtle interface (where you would set DHCP or static address) and click advanced

tt8Aswt.png

 

 

Then uncheck Automatic metric and enter a number for Interface metric:
jZx89es.png

Share this post


Link to post
Share on other sites
nik321   
1 hour ago, Lord_KamOS said:

when you share a connection with the turtle.

Can you access the internet from the turtle, or do both computer and turtle loose connection?

  

When i plug the turtle in, i can no longer access the internet on my PC. The first time i did all this it worked perfectly... i pinged google and it was fine! So after pinging google i did an "opkg update" from the terminal to update the turtle... after it finished i unplugged. And every time since then it just hasnt worked

Share this post


Link to post
Share on other sites
dbum   

what does it say if you go into CMD and type 'route print' across from Network destination = 0.0.0.0

 

miGwtPw.png

**Note mine shows two 0.0.0.0 because I have a VPN enabled

  • Upvote 1

Share this post


Link to post
Share on other sites
nik321   
16 hours ago, dbum said:

what does it say if you go into CMD and type 'route print' across from Network destination = 0.0.0.0

 

miGwtPw.png

**Note mine shows two 0.0.0.0 because I have a VPN enabled

Sorry I was unable to reply last night... I think I am limited to a certain number of posts a day. I tried your method on my windows PC... and unticked the box. But when I plug it back into my Kali machine (because i cant run the turtle.sh on my windows) - I try to find that setting in Kali and I cannot find it?

Share this post


Link to post
Share on other sites
nik321   

Please can you take a look at my pictures. This is basically me plugging the turtle in, going into the ssh of the turtle, clicking exit to bring up the turtles terminal. Typing route first to see what it is... Then following the video by doing route add default gw ... and then I run the turtle.sh > Put in my parameters (eth1 , wlan0 , then my default router gw, and then looking what it says after i run the script)

 

 

Share this post


Link to post
Share on other sites
dbum   

I thought you were trying to get to the Internet from your WiFi connection (to your Kali machine).  It looks like you are setting up your default route to point to the Turtle (I'm guessing that is probably the 172.16.84.1 address?) to get out to the Internet.

Not having a turtle, I'm a little confused.  I'm going to lookup and see what turtle.sh does and get back with you.

 

====This is what I was going to post before looking at the pictures ===

Kali:

If you type in the command "route" you should get your routing table.  It will probably have two lines that have "default" under the "Destination" column if you follow those out to the "Metric" column you should have two different numbers (the interfaces each metric is for is listed in the "Iface" column).  The higher the number the higher the "cost".  That means that when you go to the "Internet" it will pick the past of least resistance.

 

You could manually edit the route table but there is an easier way using the tool ifmetric (sets all the metrics for routes based on an interface).  This tool is not on Kali 2017 (or usually in Ubunu any more) so you need to install it (small / no dependencies)

apt-get install ifmetric
ifmetric <WiFi Interface> 10
ifmetric <Turtle Interface> 20

Then verify using the "route" command again.  Then see if you can ping out.

Share this post


Link to post
Share on other sites
nik321   

Big thank you to Dbum . He added me on Skype and was trying to help me eradicate the problem. Turns out I am just going to have to do a factory reset and hope this solves the problem.

Share this post


Link to post
Share on other sites
nik321   

Dbum successfully helped me fix this. Massive massive props to that guy!!! He told me to route del gw turtle.lan which allowed my kali to use the wifi as its main connection again... And then I just went ahead and ran the turtle.sh script and it worked! Thank you sir.

  • Upvote 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×