Jump to content

HackRF / QSpectrumAnalyzer in Windows 10?


Recommended Posts

I am trying to setup a new HackRF to hopefully get smith charts like this, https://www.youtube.com/watch?v=KikjUWMX0lE, so I can play with antenna design. I tried HDSDR which loaded, but couldn't figure out how to make it tune well enough to get rid of static. SDR# seems to have removed their nightly builds, which leaves me with few choices for Windows. I tried setting up QSpectrumAnalyzer, but I am getting an error installing it that it couldn't install sip. I tried manually installing sip, and can't see any reason it shouldn't install unless it isn't compatible with Windows 10. Anyone conquer this? Here is the pip log.

C:\Python34\Scripts\pip run on 06/21/17 10:13:26
Downloading/unpacking SIP
  Getting page https://pypi.python.org/simple/SIP/
  URLs to search for versions for SIP:
  * https://pypi.python.org/simple/SIP/
  Analyzing links from page https://pypi.python.org/simple/sip/
    Skipping https://pypi.python.org/packages/12/11/f7fee6889d91017c0e3375195ad5119afe1ecaca167d440c41d1432533f5/sip-4.19.1-cp35-none-win32.whl#md5=dd39096aac18a6784bf2cc6775ea48ad (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/17/ec/8651ca0c24595761c9b25f9fee2f3487c836eee286093e33294cae6c9924/sip-4.19.2-cp35-none-win32.whl#md5=ac81c46ada522c37d65b148824fdfa2a (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/19/5a/c50a0ccd211f864972da0f2e101722508ffb4e008347fd2a56a99beab9d0/sip-4.19.2-cp35-cp35m-manylinux1_x86_64.whl#md5=ad58ce7890e12285077e928982b2c96a (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/22/45/8af39cdd11fce2029c183caf0447d2c498aa6fe4bd0ade0cfc9297b5ae4f/sip-4.19.2-cp36-cp36m-macosx_10_6_intel.whl#md5=6d4fb4fd3ff4022a53b564b737462a26 (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/36/2c/7571c4d56d0dfc9baa5d8572aa349fdd60ea13f810aee1427691b77ef15b/sip-4.19.1-cp36-none-win32.whl#md5=23889910c30b74085a9421d744bce1a6 (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/40/48/295e0dcdb3b0180d74f8c3dd77c67e727f5aa7e4cc68005fee8c4fae92cb/sip-4.18.1-cp35-cp35m-manylinux1_x86_64.whl#md5=945654e4c3af6a7f6bcfa1b8fc2a45d8 (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/42/46/fc1c06fac246ffabc80f7f5de4a73be027112628c31594bee314954bd414/sip-4.18-cp35-none-win32.whl#md5=c9a109d5d51ba794bbd80fc305110d79 (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/4a/37/86cda76a49b767f3cf26a7b7fdb45e002d97a3ce4590e4f969b49d4eae92/sip-4.19-cp36-none-win_amd64.whl#md5=673497066d83c57c8ac08bd252592df5 (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/4a/d9/9579f01a6c2155204bf6da55509bb2287dea55709676cfc92bcd5055aa0b/sip-4.19.1-cp36-cp36m-macosx_10_6_intel.whl#md5=e1a8afad8af13dd7ccc212f4b62e4a4a (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/4d/be/b49d06739027998d06cf85c5e61cc6f87a6edd2c0ecf7496185f08f2730a/sip-4.19-cp35-none-win32.whl#md5=bbdce529873b10204da7d9dd47281da5 (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/51/63/85c2fec6498e4fa792af2640598d2fc26c048274b8fa3735164bbdd2226f/sip-4.19-cp36-cp36m-macosx_10_6_intel.whl#md5=13ebef418c63b749f5754380c528cd40 (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/53/e9/17b568b0b8cc388fe2987d8ad2904d39b06be66f069043c8c1b080d53896/sip-4.19.2-cp36-none-win32.whl#md5=d591b1f5e3c40dd850b046ebce98103c (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/56/a5/974eb9e9224eb21437f59733ca8e695cbb6507a510cd283cb664cf1ab9d7/sip-4.18-cp35-cp35m-manylinux1_x86_64.whl#md5=bb00e5761cb5c96f53df8eda0790386e (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/73/7c/7f40c734bba4523190b87bc3ac95113264bd53efc69322712002192c9823/sip-4.18.1-cp35-none-win_amd64.whl#md5=eac5005e7a55a07805f436e7a1b6780e (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/7b/d0/7c9a7b69d1504c27e65b1efb053966f3b232e9071bb99ecc447232319f98/sip-4.18-cp35-none-win_amd64.whl#md5=ab8228070b3a8e549b309013e5b199d9 (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/7d/4f/e7b0f20e4106857e85e0bf47c663427bb78434a241d36be9aeb4d400fbc0/sip-4.19.1-cp36-cp36m-manylinux1_x86_64.whl#md5=3472346aab6be1c02a928590f9a29975 (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/7e/55/903260dab5a0bd60e43377f9da9df8ad952684aa75a74c85d16ca1bdc1c4/sip-4.19.2-cp36-cp36m-manylinux1_x86_64.whl#md5=9b698fc5e19adeafabdbfc2a05e4d196 (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/8d/db/fe1df0c49ec794e4dab232142d835c1b57e2cf9f8ef101c34c840a420335/sip-4.19-cp36-none-win32.whl#md5=b8744c002e0c10cca30679deddbe30ee (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/90/e1/103eba6a762a8e48357488352221d1ec24a5c44de372d204313e1e5215f8/sip-4.18.1-cp35-none-win32.whl#md5=696162ddaff39189809df1598fac9ee7 (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/98/66/0420471445e9f2ecc7a9dff0250c804a528e25d00b844b25685c58d2a134/sip-4.19.1-cp36-none-win_amd64.whl#md5=4c9a786d9c566028d69824ef17db4ae0 (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/a1/66/8aba2d5e0f8d6c7fc43a68d4d3b2971bb2228342d94e0516cd88ae5f0464/sip-4.19-cp35-cp35m-macosx_10_6_intel.whl#md5=a373aa77b45486eea34a6c3cbe97a18a (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/a4/13/5b392334328aa01a8fac128b9b3dddfbeb71926a5e887fd2f0cac273f548/sip-4.19.1-cp35-cp35m-macosx_10_6_intel.whl#md5=0cc698a274293e64082e0b1fe9b5e21b (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/aa/61/d3e33258a7f65c17074de62a8a34bbb999e7ffb0688e562e6e68df7fde4f/sip-4.18.1-cp35-cp35m-macosx_10_6_intel.whl#md5=ebf9fb471c220daf21faa1300942f23b (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/ab/e2/3e4435da3ed818a186f04f149a769a55c84c97d345a24e6e0574cb21c10d/sip-4.19.1-cp35-none-win_amd64.whl#md5=b70a70f15ca6e0330f632363c0983f7a (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/b0/09/c5cf0f69036909c11c4f6135295f1b3600578cd6fc65737eb66c0c88436d/sip-4.19-cp36-cp36m-manylinux1_x86_64.whl#md5=e28fbe3b88e74571c8cef9ce0a4f13f5 (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/c2/1e/44017184f68c94d4fa3898ca15079868d083a05aac0d33f65cd8fed07dd9/sip-4.19-cp35-none-win_amd64.whl#md5=23c477a52b5ca5e0b5d27c61a49b59d8 (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/cb/51/8df9ae05eaa4e6c1496ebc12449f12c4dd158eb7663cfa84c8054037d50b/sip-4.19.1-cp35-cp35m-manylinux1_x86_64.whl#md5=611b993ddbd73983542fa0a8e840f9a2 (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/d4/b9/3f506d00561be860919688aa917fcf8d18ba39a7c8ad85deddfb4a346c51/sip-4.18-cp35-cp35m-macosx_10_6_intel.whl#md5=d8baf3685f55d490073a078ef62c179b (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/db/07/d17e08b8e18e021e6614622ef73d6907cc272f053373e6719e2dc1a2b7c4/sip-4.19.2-cp36-none-win_amd64.whl#md5=524c49ffb1d8c0ee1eeb591e8bce27b6 (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/ee/cc/6ebf2d859aa6f48e91ea6807d4b552135e03570b4ae8142d90d2dcb94405/sip-4.19-cp35-cp35m-manylinux1_x86_64.whl#md5=66e157bcbc8ec92d6411d101209898fa (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/f9/8c/23d88c8e4d457031111b70ec25bf97844776ec16cfd4688f318dcaeba5d6/sip-4.19.2-cp35-cp35m-macosx_10_6_intel.whl#md5=eb42e9975cae2b936ecc980b9a3266ed (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
    Skipping https://pypi.python.org/packages/fb/89/82da2474d0e2183d77a87d217589b55366d60f1101ed9abbea5c0f8fc210/sip-4.19.2-cp35-none-win_amd64.whl#md5=15d337f6696b82543350afbc9ce831e1 (from https://pypi.python.org/simple/sip/) because it is not compatible with this Python
  Could not find any downloads that satisfy the requirement SIP
Cleaning up...
  Removing temporary dir C:\Users\Alan\AppData\Local\Temp\pip_build_Alan...
No distributions at all found for SIP
Exception information:
Traceback (most recent call last):
  File "C:\Python34\lib\site-packages\pip\basecommand.py", line 122, in main
    status = self.run(options, args)
  File "C:\Python34\lib\site-packages\pip\commands\install.py", line 278, in run
    requirement_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle)
  File "C:\Python34\lib\site-packages\pip\req.py", line 1177, in prepare_files
    url = finder.find_requirement(req_to_install, upgrade=self.upgrade)
  File "C:\Python34\lib\site-packages\pip\index.py", line 277, in find_requirement
    raise DistributionNotFound('No distributions at all found for %s' % req)
pip.exceptions.DistributionNotFound: No distributions at all found for SIP

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...