Jump to content

(SOLVED) Cannot SSH into BashBunny from Debian/Linux Host


Recommended Posts

On 6/20/2017 at 0:34 PM, Lord_KamOS said:

Did you get a shell?

I have no trouble accessing this system through serial, but networking still doesn't appear to be working properly.

Link to post
Share on other sites
On 6/19/2017 at 5:55 PM, Sebkinne said:

Yup, that's it. I have it working but it's a bit slow. There are some tricks to speed it up though, so once I finish that, I'll push out a new firmware. 

That sounds great, since you seem pretty tied into the development, where would you recommend I look to find out more on the networking aspect of this project? There doesn't seem to be much documentation on the bash bunny.

Link to post
Share on other sites
On 6/18/2017 at 11:44 PM, Fang_Shadow said:

Remember that linux uses both RNDIS_ETHERNET and ECM_ETHERNET, since it wants to be compatible with both windows and unix(mac). Has the usage of both storage and another attack mode work at the same time before on linux, or could be something different.

Are you saying I should set my payload with RNDIS and ECM attack modes?

Link to post
Share on other sites
12 hours ago, Fang_Shadow said:

no i am saying to choose one or the other, but only with one attack mode (ethernet OR storage; not both)

Thank you @Fang_Shadow, this looks like it fixed the problem, albeit with slightly limited capabilities.

I now have an IP on my eth1 interface. Now I just need to configure the payload to throw me a shell, this has been a huge help!

  • Upvote 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...