Jump to content
Jay314

bb.sh Not working

Recommended Posts

I'm trying to run the bb.sh script on my debian box, to share out my network connection to the BashBunny, however the script appears to hang after saying "Detecting Bash Bunny".
Are there any guides on setting up the shared connection manually?

Share this post


Link to post
Share on other sites

are you putting the bunny on a switch with ATTACKMODE ECM_ETHERNET or trying this from arming mode?

  • Upvote 1

Share this post


Link to post
Share on other sites

so what you want to do to get ICS for the bunny via bb.sh is make a payload on either switch with ATTACKMODE ECM_ETHERNET.  you can also add another attack vector to that so SERIAL ECM_ETHERNET or STORAGE ECM_ETHERNET and us bb.sh like that.  Switch 3 or Arming mode does not support the device as an ETHERNET device, just STORAGE and SERIAL.

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks for the clarity B0n3z,

So it seems like I'll need to ssh into the bashbunny after setting up an ATTACKMODE ECM_ETHERNET payload  for what I'm trying to accomplish (which is sshing into a remote vps)

I ended up running the default payload:

#!/bin/bash

LED G

ATTACKMOD ECM_ETHERNET STORAGE

But for some reason I'm not able to ssh into root@172.16.64.1 from my local machine, nor does it appear that my NIC gets a new IP (which is what I assumed would happen after executing that payload.)

Any ideas on what i'm missing?

Share this post


Link to post
Share on other sites

I should also mention that while I don't get a new IP, i do get a new network interface: eth1, but it doesn't appear to be configured.

Share this post


Link to post
Share on other sites

I just attempted to run the bb.sh config again, while loading the attack payload, and it's still hanging.

Share this post


Link to post
Share on other sites

I got as far as bb.sh running and correctly identifying my main nic as eth0 and the gateway as 192.168.0.1 but things went awry from there. I am running the latest Kali linux x64, it seems as if the config script took eth0 down so I wasn't able to ping out getting network is unreachable.

I finally managed to get my bunny on line by tweaking things in the network control applet but to be honest I am not sure what I did to get it working. :huh:

 

 

Share this post


Link to post
Share on other sites

Could you post the settings at least? Im having the same problem. Trying to connect using bb.sh and I get through the program but then can't apt update my device.

 

  • Upvote 1

Share this post


Link to post
Share on other sites

I think i solved it but i'm not sure. I have Kali Linux, same problem with bb.sh. so i finally did a manual setup and got it to work.

I booted the bunny with switch on 2 payload text "ATTACKMODE ECM_ETHERNET"(should be the factory payload text wit LED G SLOW in line 1). the led turned green so it should work. I did get an eth1 device. i made sure both were connected. after the manual setup (make sure you read the instructions carefully) both were still connected i got the bunny detected. I go from here.

Hope it helps others.

Share this post


Link to post
Share on other sites

btw ssh w

6 minutes ago, Pentester1975 said:

I think i solved it but i'm not sure. I have Kali Linux, same problem with bb.sh. so i finally did a manual setup and got it to work.

I booted the bunny with switch on 2 payload text "ATTACKMODE ECM_ETHERNET"(should be the factory payload text wit LED G SLOW in line 1). the led turned green so it should work. I did get an eth1 device. i made sure both were connected. after the manual setup (make sure you read the instructions carefully) both were still connected i got the bunny detected. I go from here.

Hope it helps others.

btw ssh root@172.16.64.1 works fine 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...