Jump to content
Hak5 Forums
AvidPontoon

In need of some help with AUTO-SSH please

Recommended Posts

Hello

I am using autossh on the lan turtle and have setup the config to connect to my lan turtle on port 8888 then I generated a key and copied it to my VPS. This all worked and I was able to connect upon starting autossh in that same session, but after I rebooted the lan turtle I cannot get a ssh session with it. It will give me either "connection reset by peer" and then "connection refused" or just straight up connection refusal. 

 

What am I doing wrong? This has been driving me insane. There is no firewall on the vps blocking the outbound connection either.

Share this post


Link to post
Share on other sites

On the turtle, can you ssh to the host without typing in a password?
On the host that the turtle is sshing into, "netstat -nap | more" look and see if port 8888 is open.

Share this post


Link to post
Share on other sites
1 hour ago, Thecolorchanges said:

On the turtle, can you ssh to the host without typing in a password?
On the host that the turtle is sshing into, "netstat -nap | more" look and see if port 8888 is open.

The port shows up and yes I can ssh into the host, it had just worked a handful of times but now I'm getting the same "connection refused" error as before :/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×