Jump to content

Rubber Ducky encoding problem


Recommended Posts

Hello fairly new linux user here.

I run fedora 25 for encoding and decoding , since im fairly new to coding and linux im starting off simple with a hello world for the rubber ducky as shown in the quack start guide.
However when i run the command for the encoding :

ducktools.py -e -l gb /path/to/HelloWorld.txt /path/to/inject.bin

it gives me this outcome:

+] Reading Input file.
  [-] Encoding File
[!] Command String Not in Language File Is not supported as a valid command
  [-] Encoding complete
  [-] Writing inject.bin to /run/media/sloyens/A87B-A154/inject.bin
[+] Process Complete

and the script doesn't work.
Am i giving the wrong code for the distro i use ? It seems to take the command but i dont really understand what it means by language.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...