Jump to content

Restoring previous version of BB.


Bryfi
 Share

Recommended Posts

This update has not been a productive one and I am wondering if there is a safe way to revert back to 1.0. This update has broken a couple payloads for me that were working before 1.1.

Should I factory reset the BB? The said payloads (BunnyTap, Quickcreds mainly) are apparently working for others but I cannot seem to get it to work.

Edited by Bryfi
Link to comment
Share on other sites

12 minutes ago, Bryfi said:

This update has not been a productive one and I am wondering if there is a safe way to revert back to 1.0. This update has broken a couple payloads for me that were working before 1.1.

Should I factory reset the BB? The said payloads (BunnyTap, Quickcreds mainly) are apparently working for others but I cannot seem to get it to work.

Maybe try removing the line 'source bunny_helpers.sh' from the payloads. Since that line is irrelevant and the bunny_helpers.sh doesn't exist anymore, all variables being made environmental.

Also, some LED calls might not work anymore either, as that method was redone.

EDIT: Recovering my BB right now because I forgot my login, but I'll let you know if it reverts to BB version 1.0 (I will probably keep 1.0 until 1.2 comes out, as 1.1 is very buggy).

UPDATE: Recovering my BB did indeed set the version back down to 1.0_167. 

Edited by Dave-ee Jones
Link to comment
Share on other sites

8 minutes ago, Dave-ee Jones said:

Maybe try removing the line 'source bunny_helpers.sh' from the payloads. Since that line is irrelevant and the bunny_helpers.sh doesn't exist anymore, all variables being made environmental.

Also, some LED calls might not work anymore either, as that method was redone.

I have re-coded all the possible LED conflicts and fixed the lighting issue but the payload still wouldn't run. Said payloads either didn't source bunny_helpers.sh at all or were already coded for environmental variables.

EDIT: Had to keep bunny_helpers.sh for some payloads to work(WiPassDump). It's existence should not bother other payloads that don't source it.

Edited by Bryfi
Link to comment
Share on other sites

21 minutes ago, Bryfi said:

I have re-coded all the possible LED conflicts and fixed the lighting issue but the payload still wouldn't run. Said payloads either didn't source bunny_helpers.sh at all or were already coded for environmental variables.

EDIT: Had to keep bunny_helpers.sh for some payloads to work(WiPassDump). It's existence should not bother other payloads that don't source it.

Uhuh.

Recovering your BB does reset your version, by the way. As I said above :)

  • Upvote 1
Link to comment
Share on other sites

9 hours ago, Dave-ee Jones said:

Uhuh.

Recovering your BB does reset your version, by the way. As I said above :)

Nice. How did you recover? 3 times stick in and out? Or do I use a command. I forget xD

EDIT: Figured it out. So happy I got this version now. Thank you so much!

Edited by Bryfi
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...