Jump to content

Tool_installer


Pancakes
 Share

Recommended Posts

7 hours ago, Pancakes said:

The tools_instller hasnt worked since 1.1 upgrade. Ples help me fix this

 

2 hours ago, trumoo said:

Same. How do we install impacket manually?

To install responder and impacket manually.

  1. Copy the impacket and responder folders to the /tools folder on the root of the mass storage partition.
  2. Unplug the BashBunny and plug it back in with the switch in Arming Mode.
  3. The folders will be automatically moved to the /tools folder on the OS partition of your BashBunny
  4. Serial into the BashBunny, change directory, cd /tools/impacket and run `python ./setup.py install`
  5. Responder and impacket are succesfully installed.
Edited by LowValueTarget
Link to comment
Share on other sites

After the upgrade I blindly blew away the old libraries on my BB and put the new ones...which did not have the old tools prepackaged.  I ended up having to clone the current repos of impacket and Responder and put them in the tools on the usb partition and followed directions of safe unmounting, unplugging and replugging in BB.  It copies them to the linux partition under /tools.

Responder just worked when I tested on SSH.  impacket stuff did not until I did the install which it then placed stuff in /usr/local/bin and and all the scripts began to work.  See this as a cross board compatibility issue with only paths like when someone does SMB exfiltration or Quickcreds they will probably have to modify the path to their tools.  The extension for RequireTools will not work for all since their tools maybe not in the /tools folder on the linux partition.

Seen the linux partition apt folder has a sources.list to debian.  Does that mean you can apt update and upgrade the BB or will it break their image doing so?

 

Edited by PoSHMagiC0de
Link to comment
Share on other sites

5 hours ago, PoSHMagiC0de said:

After the upgrade I blindly blew away the old libraries on my BB and put the new ones...which did not have the old tools prepackaged.  I ended up having to clone the current repos of impacket and Responder and put them in the tools on the usb partition and followed directions of safe unmounting, unplugging and replugging in BB.  It copies them to the linux partition under /tools.

Responder just worked when I tested on SSH.  impacket stuff did not until I did the install which it then placed stuff in /usr/local/bin and and all the scripts began to work.  See this as a cross board compatibility issue with only paths like when someone does SMB exfiltration or Quickcreds they will probably have to modify the path to their tools.  The extension for RequireTools will not work for all since their tools maybe not in the /tools folder on the linux partition.

Seen the linux partition apt folder has a sources.list to debian.  Does that mean you can apt update and upgrade the BB or will it break their image doing so?

 

The Debian apt does not install the files to the /tools. I tried this with impacket. It works, but all checks from Fw 1.1 requiretool impacket and so on fails. 

I decided to make my own deb file and with postinstallation script so impacket installs find to /tools and does the setup.py in the deb file postinstallation script

Link to impacket.deb

Edited by qdba
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...