Jump to content

Windows 10 x64 CDC ECM driver issue (Solved!).

Albert Altman

Recommended Posts


When I am trying to install the tools_installer payload the bash the green led is plain solid and windows 10 can seem to be able to install the driver for ATTACKMODE SERIAL I guess ?

Did anyone manage to solve this ?

I can connect to it via SSH (Serial) when in arming mode so I am not sure what is going on.

I did try the automatic driver search function and google around a bit for a generic driver but I am still a bit stuck.


Can anyone help ?





Edited by Albert Altman
solved the issue
Link to comment
Share on other sites

Just to check but did you change the attack mode on the payload for the tools install or setup a payload and use it to set attackmode to "RNDIS_ETHERNET"?  I see ECM above.  That is used for Linux and Mac systems that will not need to have extra drivers.  RNDIS will install on Windows without drivers, including Windows 10.  Also you will need to share the ethernet connection to install dnssniff.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...