Jump to content
Hak5 Forums

Setup Loop - Cant Install Firmware

Recommended Posts

Hi everyone.

I've just unboxed my Pineapple Tetra and I'm following the setup steps. However, the process gets stuck in a loop around the firmware installation.

I get to the "Install the Latest Software" page. I choose the downloaded .bin file and click upgrade. The file uploads, and I'm taken to the "Upgrade file verified successfully" page. However, rather than actually installing the update it simply returns to the "Install the Latest Software" page after 10 seconds. No flashing blue light or other indication of progress.

I've tried different firmware versions. I've tried over USB Ethernet and wifi. I've tried Chrome and Firefox. I've tried Windows and Mac. I've tried powering the Pineapple using the power supply or USB to make sure it is sufficiently powered.

Has anybody any ideas to get around this? Am I simply doing something stupid here? Are there any other ways to install firmware or get the thing running?

Thanks for your help.


Share this post

Link to post
Share on other sites

And of course I was doing something stupid. I have a Nano and a Tetra and had mixed up my firmware downloads.

My excuse is that the filenames are pretty much identical. And I have the flu. Would be better if an error was generated though rather than just dropping it back to the upload page... Using sysupgrade via the command line gave an error which is how I realised my stupidity.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.