Jump to content

Reporting Issue


jedwards
 Share

Recommended Posts

Hello Community,

I am trying to send reports to my gmail address. I think I setup the ssmtp.conf file correctly and filled out the Reporting module correctly in the GUI as well. If you look at the System Log below you'll see there's a "555 5.5.2 Syntax error. j4sm2875006ita.29 - gsmtp"....... I've double checked the ssmtp.conf file and I don't see any syntax errors or "gsmtp" in the file.

Could someone please take a look at the screenshots below and let me know if I am missing anything?? THANK YOU FOR YOUR HELP! I love this tool.

 

Sat Mar 25 20:00:00 2017 cron.info crond[1016]: USER root pid 21928 cmd /pineapple/modules/Reporting/files/reporting
Sat Mar 25 20:00:19 2017 mail.info sSMTP[21988]: Creating SSL connection to host
Sat Mar 25 20:00:19 2017 mail.info sSMTP[21988]: SSL connection using ECDHE-RSA-AES128-GCM-SHA256
Sat Mar 25 20:00:19 2017 mail.err sSMTP[21988]: 555 5.5.2 Syntax error. j4sm2875006ita.29 - gsmtp

 

SSMTP.CONF

# /etc/ssmtp.conf -- a config file for sSMTP sendmail.
#

# The person who gets all mail for userids < 1000
# Make this empty to disable rewriting.
root=johndoe123@gmail.com

# The place where the mail goes. The actual machine name is required
# no MX records are consulted. Commonly mailhosts are named mail.domain.com
# The example will fit if you are in domain.com and your mailhub is so named.
mailhub=smtp.gmail.com:465

# Example for SMTP port number 2525
# mailhub=mail.your.domain:2525
# Example for SMTP port number 25 (Standard/RFC)
# mailhub=mail.your.domain
# Example for SSL encrypted connection
# mailhub=mail.your.domain:465

# Where will the mail seem to come from?
rewriteDomain=gmail.com

# The full hostname
hostname=mail.gmail.com

# Set this to never rewrite the "From:" line (unless not given) and to
# use that address in the "from line" of the envelope.
FromLineOverride=YES

# Use SSL/TLS to send secure messages to server.
UseTLS=YES

AuthUser=johndoe123@gmail.com
AuthPass=johndoe123
 

# Use SSL/TLS certificate to authenticate against smtp host.
#UseTLSCert=YES

# Use this RSA certificate.
#TLSCert=/etc/ssl/certs/ssmtp.pem
 

Email Configuration

From: I left this field empty (not sure if this is my problem as the ssmtp.conf file states it does not need to be given. Maybe it does?)
To: johndoe123@gmail.com
STMP Server: smtp.gmail.com
SMTP Port: 465
Domain: gmail.com
Username: johndoe123@gmail.com
Password: johndoe123
Use TLS: checked
Use STARTTLS: unchecked
Link to comment
Share on other sites

  • 5 months later...

I never really needed to use the reporting module, until today. I am also having the same/similar issue as above. I searched the forums for reporting module issues and found some things to try but so far nothing has got me working.... yet :)

I found the gmail smtp data here https://support.google.com/a/answer/176600?hl=en              It says that gmail uses Port 465 (when using SSL) and Port 587 (when using TLS). I have tried using both checking TLS box for port 587 and STARTTLS for port 465. but either way im getting "failed to send email to" messages in the /tmp/reporting.log

has anyone got reporting module to work with gmail? if so would you post your successful settings in the module and /etc/ssmtp/ssmtp.conf. Thank you.

EDIT - i even tried enabling "Allow less secure apps to access accounts" in google account settings which i think disables a capture for sign in? but didnt change. I will keep trying.

EDIT EDIT  - Evenually got it working with gmail thanks to the peeps on IRC. and some trial and error - used port 587 and STARTTLS selected only. finally worked well.

EDIT EDIT EDIT - I turned off the "Allow less secure apps to access accounts" setting on the account and it failed again so looks like its needed. At least for me, YMMV.

 

Edited by Just_a_User
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...