Jump to content
nutt318

Internet connection on Windows

Recommended Posts

Not getting it : 

 

I have set the attackmode to ATTACKMODE RNDIS_ETHERNET

Selected that switch :)

I share my Wifi connection

The connection is enabled; IP set to 172.16.64.64 / 255.255.0.0

 

Yet : when i try to ssh into the BB : i get 'Connection Refused

 

 

 

2017-04-14 15_18_00- Internet connection on Windows - Bash Bunny - Hak5 Forums.jpg

2017-04-14 15_19_14-Ethernet 3 Status.jpg

 

OS : Windows 10 Enterprise / 16 Gb / Inten Dual Band Wificonnector

Edited by Dice
extra information

Share this post


Link to post
Share on other sites
On 4/14/2017 at 3:19 PM, Dice said:

Not getting it : 

 

I have set the attackmode to ATTACKMODE RNDIS_ETHERNET

Selected that switch :)

I share my Wifi connection

The connection is enabled; IP set to 172.16.64.64 / 255.255.0.0

 

Yet : when i try to ssh into the BB : i get 'Connection Refused

 

 

 

2017-04-14 15_18_00- Internet connection on Windows - Bash Bunny - Hak5 Forums.jpg

2017-04-14 15_19_14-Ethernet 3 Status.jpg

D

OS : Windows 10 Enterprise / 16 Gb / Inten Dual Band Wificonnector

Disregard this; 

I was trying to connect to the wrong end of the BashBunny; 

 

Appartently the 'attack-side' of the ethernet connection does allow ssh traffic ... My bad

Share this post


Link to post
Share on other sites
6 hours ago, Fang_Shadow said:

Subnet is 255.255.255.0 for the BB

Without a default gateway that does not matter; 

The only difference on this subnet set it expects 65534 hosts to be available on the local subnet before moving packets onto the default gateway.

 

 

However my mistake was different; I set the IP to 172.16.64.64 manually and expected that side of the BB to answer to SSH commands.

If i hadnt set that IP it would have gotten an IP from the internal DHCP server and been given a different Ip address. (172.16.64.10-12)

the SSH commands are meant to be started from the 172.16.64.1 IP.

 

Share this post


Link to post
Share on other sites

I know this is a old post. Instead of making a new one i figured i post here. 

 

The issue i have is everything is set up via wiki, i can ping to it from the windows machine but not from the BB every time i ping it never times out but it will keep going forever till i do. I can even SSH into it with no issue. Any idea? im using switch two. 

Share this post


Link to post
Share on other sites
23 hours ago, super-6-1 said:

I know this is a old post. Instead of making a new one i figured i post here. 

 

The issue i have is everything is set up via wiki, i can ping to it from the windows machine but not from the BB every time i ping it never times out but it will keep going forever till i do. I can even SSH into it with no issue. Any idea? im using switch two. 

What are you trying to ping? If you are trying to ping the BB it won't work very well because the BB is configured to ignore pings. Darren showed us how to make it respond to pings by using this command:

echo "0" > /proc/sys/net/ipv4/icmp_echo_ignore_all

(Well, I believe that is what it does anyway. @Darren Kitchen or @Sebkinne, can you confirm?)

And you probably would have been better off with a new post instead of hiding out in an older one :P Just a suggestion.

 

Share this post


Link to post
Share on other sites
On 5/31/2017 at 9:52 PM, super-6-1 said:

I know this is a old post. Instead of making a new one i figured i post here. 

 

The issue i have is everything is set up via wiki, i can ping to it from the windows machine but not from the BB every time i ping it never times out but it will keep going forever till i do. I can even SSH into it with no issue. Any idea? im using switch two. 

To clarify, you can SSH in, but are not getting an internet connection while SSH'd into the BB?

Share this post


Link to post
Share on other sites

IT WORKS! For anyone else still struggling with this problem here's how I fixed it. Note: I'm running Windows 10 and sharing connection from Ethernet 1 (windows NIC) to Ethernet 4 (BashBunny NIC). I basically had to reset the network sharing by doing this,

  1. Press [WindowsKey]+[r] and type "ncpa.cpl"
  2. Right click the Windows NIC (Ethernet 1 in my case) and select properties
  3. Click the "sharing" tab
  4. Uncheck both boxes and click "ok"
  5. Disable all network cards by right clicking and selecting disable....after a second or two re-enable the Network cards.
  6. Right click the Windows NIC (Ethernet 1 in my case) and select properties
  7. Click the "sharing" tab
  8. Check the first checkbox saying "Allow other network users to connect through this computer's Internet connection"
  9. In the text box type or select the dropdown for your BashBunny network ("Ethernet 4" in my case). Click ok
  10. Right click your BashBunny NIC (Ethernet 4 in my case) and select properties.
  11. Select "Internet Protocol Version 4 (TCP/IPv4)" and click properties. You'll see some random ip address here.
  12. Enter the ip: 172.16.64.64 and subnet: 255.255.255.0 and leave the rest blank. Click Ok..and Ok again. 
  13. SSH into your BashBunny and try pinging google (type: ping google.com) and it should work.

 

Share this post


Link to post
Share on other sites

Quick Note, do NOT use the set your Windows BashBunny Nework interface to use the DHCP option from BashBunny!  It will put a gateway in for you of 172.16.64.1 (BashBunny IP)  and then you will have 2 gateways on Windows which messes up your internet traffic because it conflicts with your main NIC that points towards Internet. Now you can't get to the internet. I'm sure that's why a few of the people couldn't get ICS to work. Setup the BB Windows Adapter to be 172.16.64.64/24 (as the document says) and leave DNS and gateways entries BLANK in Windows. 

BashBunny's linux distro has the gateway it should route out of as 172.16.64.64, which is why the document specifically tells you to set YOUR WINDOWS BashBunny Adapter to that specific IP.  If you change your NIC IP, then you need to change the default route in BB Linux. BB routes to that NIC, then out through the one you set up for ICS. 

Share this post


Link to post
Share on other sites
On 4/13/2017 at 12:58 PM, devildog31415 said:

what doesn't work is apt-get update.. it just times out.

Need to post the output of this.  Are you sure your repos are correct for apt update?  You seem to have a good network connection from your post.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...