Jump to content

Internet connection on Windows


Recommended Posts

I'm trying to get the Git-Bunny-Git payload to work on switch 2. My device shows up as Ethernet 2 (running windows) and I follow the instructions on the FAQ (http://wiki.bashbunny.com/#!./index.md#Sharing_an_Internet_Connection_with_the_Bash_Bunny_from_Windows) but still cannot get the payload to work.

I'm just getting a red error light meaning to internet connection. Instructions say to set the IP to, i've done that along with IP'ing with a similar IP on my LAN connection. Looking at the logs in /var/log/git.log just say no internet connection.

Do I need to use the BB.sh script or is that only for a nix machine? Any help is appreciated.


Link to comment
Share on other sites

Hi Nutt318,

Just had similar problem, but I have set the windows nic (the bash bunny one) to rather than .10 and all seems to work (in terms of getting the internet connection)

My problem now is that do I need to install git on the bunny before I run the script


Link to comment
Share on other sites

@Sl0thy2406 Git should be installed by default. Let me know if it isn't cause I might need to change my payload.

@nutt318 looks like your are trying to run my payload! Sweeeet. Sorry you are having troubles with it. bb.sh is only for linux machines. Follow the guide on the wiki for sharing the internet connection with a pc. Let me know if you get it working, because I didn't test it on a pc. If you want to try bb.sh, it should work through a vm:

Note: it will not work in arm-mode because it needs to share the internet connection, and internet sharing only work in the other two switch positions.

Link to comment
Share on other sites

I've tried switching the payload to Switch 1 and still no luck. I've also changed the ip to and while its plugged in on Switch 1 I can ping the Bunny on the ip. However I cannot SSH into it. It does have git installed but for some reason I still cannot get internet access to it. The Payload just turns solid red after a bit.

Anyone have any other ideas?

Link to comment
Share on other sites

10 hours ago, Draxiom said:

Was the machine you got it running on a pc/windows? What version?

Machine that didn't work was Windows 10 Pro 64bit, 

Machine that did work was Windows 7 Pro 64bit


Let me know if you need anything else

Link to comment
Share on other sites

The configuration file advertise  :

Configured for linux by default.



But on the BB WIKI it says that :

ECM_ETHERNET     ECM - Ethernet Control Model,  is rather suited for :   Linux/Mac/Android Ethernet Adapter


can one use ECM_ETHERNET on windows ?

(if so, how to install the drivers ?)



Link to comment
Share on other sites

I have the same problem as nutt318 and I'm running a windows 10 Professional machine and can't get internet access to work, even when following the wiki step-by-step. 

The internet speed shows 0 bps as you can see in the picture. I am able to login in to the BashBunny via SSH at ip which I think its a bit weird when you set the IP of the device on the wiki to something else. If someone can help me out that would be greatly appreciated. 



Link to comment
Share on other sites

  • 2 weeks later...

When trying to get the bash bunny to have internet sharing with windows (10 in this case), you need to put the bunny in ARMING mode (closest to the usb port), and change the payload.txt to the following:


select the switch that you have put this payload into. Your computer should recognize the device and start installing drivers, to make sure your computer sees it properly try SSH into it with default root and hak5bunny. It should also be viewable from network connections window.(Control Panel\Network and Internet\Network Connections)

Go into the properties of your main network interface (internet interface) and go to the sharing tab, tick the Allow sharing to other devices and select the bash bunny RNDIS interface from the drop down menu (some machines need to have no devices named 'Ethernet' for bunny to show up). By default the bunny gives your computer from its DHCP server, SSH into the bunny and do

ping (google dns)

If the bunny gets responses to the ping request then it is connected to the internet, else you need to set a static ip for the bunny RNDIS interface in the network connections.

[Bunny RNDIS Device]\Properties->ipv4-> static ip:

These methods should work for obtaining internet on bash bunny, else something on your system might not like sharing or the wrong interface is being used for sharing.

Link to comment
Share on other sites

I can ping real world IP addresses from the bunny ssh, and it can resolve dns to an IP. but I can't actually connect to get content.  Here I show me doing a ping to an IP, then a ping to a dns name and both work. what doesn't work is apt-get update.. it just times out.  Please advise:


root@bunny:~# ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=56 time=15.8 ms
64 bytes from icmp_seq=2 ttl=56 time=12.0 ms
64 bytes from icmp_seq=3 ttl=56 time=12.8 ms
64 bytes from icmp_seq=4 ttl=56 time=12.4 ms
64 bytes from icmp_seq=5 ttl=56 time=110 ms
--- ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4005ms
rtt min/avg/max/mdev = 12.017/32.720/110.459/38.892 ms
root@bunny:~# ping www.cisco.com
PING e2867.dsca.akamaiedge.net ( 56(84) bytes of data.
64 bytes from a23-193-69-111.deploy.static.akamaitechnologies.com ( icmp_seq=1 ttl=56 time=19.5 ms
64 bytes from a23-193-69-111.deploy.static.akamaitechnologies.com ( icmp_seq=2 ttl=56 time=12.7 ms
64 bytes from a23-193-69-111.deploy.static.akamaitechnologies.com ( icmp_seq=3 ttl=56 time=104 ms
--- e2867.dsca.akamaiedge.net ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 12.793/45.682/104.736/41.847 ms
root@bunny:~# apt-get update
0% [Connecting to httpredir.debian.org (]

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...