Jump to content

Problems with updating/installing programs in the linux "box"


Recommended Posts

Did anyone of you get a working internet connection?

I am trying to apt-get update, but it just continue to connect to httpredir.debian.com...

root@bunny:/pentest/impacket/examples# apt-get update
0% [Connecting to httpredir.debian.org (]


I think I need to update because every time I try to run rdp_check.py I get The error under:
root@bunny:/pentest/impacket/examples# rdp_check.py
CRITICAL:root:pyOpenSSL is not installed, can't continue

Link to comment
Share on other sites

8 minutes ago, rastating said:

Yup and when I ssh into it it works like normal, just that internet connection wont work :/ And I cant use rdp checker without pyOpenSSL which I need a network connection to download and install :/

Link to comment
Share on other sites


I've the same problem. I can configure the ethernet-connection in Windows 10, but if I connect via ssh-terminal, it doesn't work. If tried a ping to an IP-number and a domain but if got no answer. Maybe Bush Bunny is offered to early - it's looks like an early Alpha-Version :-(


Link to comment
Share on other sites

12 hours ago, Black_chameleon said:

I deleted the network connection in Windows twice and started over....

Then on the third try, internet!! I have no clue what I did differently.  Maybe try again?


9 hours ago, crackdraco said:

My experience was similar.  i booted the device, configured the 'NDIS' adapter, removed the adapter and repeated - at least a half dozen times.  Then apt-get worked.  It did nothing as the device was up to date.

Hey since you managed to get it working, could you share a screenshot of your settings? Like how the connection is set up and so on? I cant get it to work...

Link to comment
Share on other sites

To get apt working, just follow this part on the wiki and then SSH into the BashBunny using PuTTy or KiTTy with IP

Works for me, as you can see:

root@bunny:~# ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=45 time=18.4 ms
64 bytes from icmp_seq=2 ttl=45 time=14.9 ms
64 bytes from icmp_seq=3 ttl=45 time=18.2 ms
--- ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 14.949/17.190/18.419/1.587 ms
root@bunny:~# apt-get update
Ign http://httpredir.debian.org jessie InRelease
Hit http://httpredir.debian.org jessie Release.gpg
Hit http://httpredir.debian.org jessie Release
Hit http://httpredir.debian.org jessie/main armhf Packages
Hit http://httpredir.debian.org jessie/main Translation-en
Reading package lists... Done


Link to comment
Share on other sites

I've encountered similar issues.  If there is any sort of proxy firewall, that can play havoc as it doesn't propagate to the bunny.  Also, I have found that if docker is installed on the host, it, too, can play havoc with the forwarding (even if not behind a proxy).

I've had to flush the IP tables and rerun the bb.sh to get it to work.

Moreover, when behind a proxy, I've found to get the bunny to work with the Internet, go in and manually reconfigure the bunny's /etc/resolv.conf (where google's DNS may not be accessible behind a firewall).  Manually tweaking /etc/apt/apt.conf and possibly for good measure /etc/environment with the various proxy/configuration variables in place also helps.

E.g., /etc/apt/apt.conf

Acquire::http::Proxy "http://proxy.example.com:1080/";
Acquire::https::Proxy "http://proxy.example.com:1080/";

After configured, you'll probably want to undo your changes so you can deploy it as desired.

Link to comment
Share on other sites

  • 4 weeks later...

I've read through all posts but I'm still unable to connect my bash bunny online:( 
I have Windows 10; I disabled my firewall and network protection, I set up network sharing; set IP address of Bash Bunny adapter to and mask to (all the other fields, like default gateway and both DNS servers are empty). When I go to putty and SSH to I'm able to connect. From Bash Bunny, I'm able to ping successfully, but nothing further on the way.
My wifi internet adapter in Windows has following setup:

   IPv4 Address. . . . . . . . . . . :
   Subnet Mask . . . . . . . . . . . :
   Default Gateway . . . . . . . . . :

My BashBunny adapter:

Ethernet adapter BashBunny:

   Connection-specific DNS Suffix  . :
   IPv4 Address. . . . . . . . . . . :
   Subnet Mask . . . . . . . . . . . :
   Default Gateway . . . . . . . . . :

As you can see, the Default gateway is not assigned which might probably be the reason I'm unable to connect anywhere from Bash Bunny. When I try to ping, or I'm not successful, the only success is the ping

The setup of ifconfig on BashBunny is following:

usb0      Link encap:Ethernet  HWaddr 5a:00:00:5a:5a:00
          inet addr:  Bcast:  Mask:

Can you please help me in making it work? I'm out of options...

Thank you all

Link to comment
Share on other sites

  • 3 months later...

I had a similar problem. If apt-get is stuck at 0% [Connecting to httpredir.debian.org (IPV6 ADDRESS HERE) ] you might be having problems resolving IPV6 addresses.

You can force apt-get to use IPV4 by using:

apt-get -o Acquire::ForceIPv4=true update


apt-get -o Acquire::ForceIPv4=true install linux-app-name
Link to comment
Share on other sites

  • 2 months later...

Don't use bb.sh

Plug in your bunny and use this:

ifconfig eth1 netmask
iptables -X
iptables -F
iptables -A FORWARD -i eth0 -o eth1 -s -m state --state NEW -j ACCEPT
iptables -A FORWARD -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A POSTROUTING -t nat -j MASQUERADE
echo 1 > /proc/sys/net/ipv4/ip_forward

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...