Jump to content

initial setup security


Recommended Posts


dear all, 

today i received my wifipineapple tetra model MK5.8 

i followed the tutorial videos how to setup on a linux box. i am using kali linux  Debian 4.6.4-1kali1

connecting an usb cable to tetra eth1 i can see an additional interface eth1 on my linux box. opening a browser ( i tried with firefox and chromium ) i can connect to  and the pineapple logo appears. 

than i press the "Continue" button and i come to the "Initial Setup Security" screen. ( ) 

as recommended i press the button on the backside of tetra and than pressing the "continue" button. but nothing happens. i also tried to press the button more than 3 seconds. but there is no difference. 

i tried the same on my android phone. i installed the app from play store but i could never go over the step pressing the second time the "Continue" button. it always falls back to the same screen. 

currently i do not know how to continue if i cannot reach the web interface. 

i have seen i can login to command line if i connect the usb cable to the UART interface using "screen" or "picocom". 

any help would be nice. 

kind regards 










Link to comment
Share on other sites

A common problem I've seen with the tetra is the reset button not working or not being pressed enough.  I'm not saying you didn't press it but make sure you feel the click of the button. Others that have had this problem cut the tab out and use a pen to hit the button. I just got my tetra about 2 or so weeks ago and the reset button works but I've thought about cutting the reset tab because it never seems like I'm actually pressing it 

Link to comment
Share on other sites

We have become aware of a manufacturing anomaly which has caused a small number of WiFi Pineapple TETRA buttons to "stick".


Unfortunately this prevents the completion of the initial setup security process. Thankfully this can be remedied by the user with this simple procedure:


  1. Follow the instructions at wifipineapple.com/tetra to flash the latest firmware.
  2. When prompted to press the reset button, FIRMLY press and hold the dimple end of the reset button with a pen or similar instrument for 1-2 seconds.
  3. Click the Continue link on the setup page.
  4. Repeat steps 2-3 as necessary until setup continues.


See the following video guide for an illustration:


For the vast majority of users, this fix solves the button issue. If this does not for you, please let us know and we will begin the warranty process in order to exchange your WiFi Pineapple TETRA.

  • Upvote 1
Link to comment
Share on other sites


dear all,

first i tried to follow the instructions in the video. i repeated this process several times as recommended. i have to say i feel and i hear the click of the switch very well. it's not a mechanical issue. but maybe the switch is badly soldered. 

next i tried a firmware recovery following this instructions:  https://wifipineapple.com/pages/faq

i never managed that the yellow LED stays stable. even if i press the button much more than 10 seconds the light goes off after 10 seconds after connecting to the external power. it behaves in the same way as i would not press the button. 

any ideas what i could do ? 

btw, serial number is S/N 1454817


kind regards 






Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...