Jump to content
Smarty

Error installing Kernel Modul (usb-audio)

Recommended Posts

Hi!

I seem to be having a problem with installing a kernel module on the Tetra.
It's running the latest firmware. Installing any other module works just fine, except for kmod-usb-audio.

Error:

Configuring kmod-usb-audio.
modprobe: can't change directory to '': No such file or directory
modprobe: can't change directory to '': No such file or directory

 

afterwords its listed als installed program but not displayed when i give a lsmod.
any thoughts? I cant seem to find the answer to this modprobe problem on any openWRT related forums.

Problem is consistent on more than one Tetra

FULL ERROR:

 opkg install kmod-usb-audio
Installing kmod-usb-audio (3.18.20-1) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/base/kmod-usb-audio_3.18.20-1_ar71xx.ipk.
Multiple packages (kmod-usb-core and kmod-usb-core) providing same name marked HOLD or PREFER. Using latest.
Installing kmod-sound-core (3.18.20-1) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/base/kmod-sound-core_3.18.20-1_ar71xx.ipk.
Installing kmod-input-core (3.18.20-1) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/base/kmod-input-core_3.18.20-1_ar71xx.ipk.
Configuring kmod-input-core.
Configuring kmod-sound-core.
Configuring kmod-usb-audio.
modprobe: can't change directory to '': No such file or directory
modprobe: can't change directory to '': No such file or directory
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-audio:
 *      kernel (= 3.18.20-1-7bed08fa9c06eb8089e82c200340ec66) *         kernel (= 3.18.20-1-7bed08fa9c06eb8089e82c200340ec66) *         kernel (= 3.18.20-1-7bed08fa9c06eb8089e82c200340ec66) *
 * pkg_run_script: package "kmod-usb-audio" postinst script returned status 1.
 * opkg_configure: kmod-usb-audio.postinst returned 1.
If the above errors were only about a kernel version missmatch, please ignore them. The package was installed successfully.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...