Jump to content
TheFuzzyFish

Physically, what is wlan0-1?

Recommended Posts

Okay okay I know, hold on. Before you mark this question as a repeat question and yell at me to search the forums a little bit harder, hear me out.

So I recently became the (very) proud owner of a Wi-Fi Pineapple Tetra. I'm fairly well-versed in terms of the Linux system layout, but there is one thing that confuses me...

For those of you who are unaware, (and this is the part where I need guidance, as I may be wrong) a Wi-Fi Pineapple Tetra is equipped with 2 radios, each radio having 2 antennas to meet a total of 4 antennas. That fact alone was pretty difficult for me to find, because looking at it from the operating system, I was under the impression that there were 3 radios, which is what has been confusing.

All the schematics and descriptions I've seen describe the Tetra as having 2 radios... but then, how can there be three wireless interfaces? An even better question, how can they operate independently (I.E. one be in monitor, one be in managed, and one be in master mode)?

Here is my hypothesis: there are 2 radios, wlan0 and wlan1. Wlan0-1 is somehow a hybrid of the two, utilizing some weird feature that allows us to make a pseudo-interface that isn't actually linked to a specific piece of hardware, but instead shares the workload between the two radios... but that violates the fact stated in the statement above: they can all act independently of one another.

Then, another article I read described wlan0 as the first radio and wlan0-1 as the second radio, but then, where did wlan1 come from? I thought it only had 2 radios?

I understand that wlan0 is the open/hidden AP from the Networking module and that wlan0-1 is the managed AP, that much I gathered from /etc/config/wireless.

So I guess my final question is simple:

Can someone please please please please help me understand where these radios are on the actually hardware device?? I'm looking into building some upgraded antennas for parts of the Pineapple, and I'd like to know exactly how they will affect what. I do know that wlan0 is hooked up to the two antennas closest to the ethernet port, and that wlan1 is the two antennas closest to the reset button, but that still leaves the vital question: where is wlan0-1?

Plus, I'm curious and confused. Those two aspects of me like to combine into either hours of research, or a forum post. I've tried hours of research with no results, and so here I am.

 

Any help would be greatly appreciated. Cheers!

Share this post


Link to post
Share on other sites

I think you are overthinking the radios a little bit.

There are indeed two radios, two antennas for each. wlan0 is for the public AP, wlan0-1 is for the management AP. They both use the same physical radio, but are two different logical interfaces. Here is an excerpt from /etc/config/wireless (Note they both use the same device):

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Public_AP'
        option encryption 'none'
        option hidden '1'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2+ccmp'
        option ssid 'Management_AP'
        option key 'redacted'
        option disabled '0'

I hope that clears it up.

Edited by Foxtrot

Share this post


Link to post
Share on other sites
10 minutes ago, Foxtrot said:

They both use the same physical radio

OH!!! Everything makes a whole lot of sense now!

So wlan0 and wlan0-1 are the same hardware interface, just managed by different "programs" (put in quotes because it's actually managed by the kernel, not necessarily a program in the sense that people are used to using the term) on the data-link layer, and wlan1 is a completely different hardware interface. Might explain some things, especially the goofy MAC addresses.

Excellent! Thank you very much for the speedy and accurate response.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...