Jump to content

Management AP not working


Recommended Posts

3 hours ago, user9234 said:

I can factory default it, it will work for a few minutes, but then all of a sudden all wifi connections begin to fail until it is factory defaulted again. Rinse and repeat.

It doesn't sound like you have tried a firmware recovery, not factory reset. Maybe you have but it doesn't sound like it based on the above.

  • Upvote 1
Link to comment
Share on other sites

  • 1 month later...

Same here. Bought a NANO at DefCon. Firmware 1.1.3. After clicking "Update" on the Networking tab I can connect to the Management SSID until a reboot. After that I must connect wired. Kind of hard to switch from wired to battery power without rebooting... so I can't connect to the Management SSID unless I'm also wired. Happens 100% of the time.... or at least 50 out of the first/last 50 times I've tried.

Link to comment
Share on other sites

  • 2 months later...

I live in the UK and own a computer repair business. I bought my Nano from Amazon, I also bought a WiFi adaptor that did not work with the Nano so plugged in my Alfa AWUS036NEH and connected it to my WiFi network.

I started following the video tutorial and all looked good. I used an Anker 5000 PowerCord battery to power the Nano.

After about 10 minutes the management interface locked up. From this point on I am experiencing the same problems listed above and also detailed on the WiFi Pineapple bug sites. Only a factory reset works and then this is only a temporary fix. Neither of my Dell laptops connect (Kali and Windows 7) but my Samsung A5 phone can connect sometimes but this is not how I wanted to use the Nano.

My initial thought was that I plugged in the Alfa USB adaptor. This is a big adaptor and I am wondering if it pulled too much power from the battery which caused a component failure in the Nano. This may be why the techies at Hak5 and WiFi Pineapple have not been able to reproduce the problem.

Thankfully I bought mine from Amazon and will be returning it. I will be buying another one when I see a fix but as this has not been resolved for over a year I am reluctant to wait. I perform security demos and reliable equipment is not something I need to be worrying about.


Before I press submit to this post................

I was following the video and testing with my own phone when the management interface locked up. I was on my network therefore my phone was in the allow filter list. I removed it from the filters and switched back to deny with an empty filter list. Guess what, my laptops could connect again. Does this mean that whenever I set up an allow filter list I have to add my own devices? Is this how the nano was designed. I would have thought that any device could connect to the management AP but only filtered devices to the open WiFi. Btw, whilst my phone was in the allow filter list it never appeared as a client and my phone was stating "Authentication Error".

I will see how I get on over the weekend. In theory the Nano is an exciting piece of kit




Link to comment
Share on other sites

9 minutes ago, BusiFix said:

Does this mean that whenever I set up an allow filter list I have to add my own devices?

Currently, yes this is the case for both wlan0 (open) and wlan0-1 (management network). "If you ain't allowed you ain't coming in"

In the past I have been out and about and managed to lock myself out with no OTG cable so had to wait until I was back to my laptop to restore access lol its a lesson to learn from :)

Ideally it would be useful to have a separate filter for both wlan0 and wlan0-1.

I didn't think Hak5 sold through Amazon, so not sure who's selling them through there.  I would imagine its someone selling new as used or someone marking up the price a little and reselling. maybe wrong tho.

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...
On 12/7/2017 at 10:20 PM, frankthorn said:

I had this issue occur today and found that somehow, my device's MAC was added to blacklist. Once removed, all was well. 

Know that if you black list a mac address with the Connected Clients module, you can’t remove them from the filter module until you un-blacklist it.

Link to comment
Share on other sites

  • 4 weeks later...
  • 9 months later...

So the issue i have is this: i finally get the W-Fi client connected and log into it with a device then i go to use the pineapple but the connection has gone and reverted to wlan1, PineAP keeps disabling when i connect the wifi client effectively making it useless from a remote perspective. 

using a laptop no problem but as soon as i try and create the Wifi client it connects then disconnects and reverts. despite it being wlan1mon when PineAP is connected..............something is reseting the device but what

Link to comment
Share on other sites

  • 8 months later...

I'm having a similar issue with my Tetra. The management and open SSID appears and disappears repeatedly every 10 or 15 seconds. I had the issue with version 2.6.0 firmware, ran a factory reset, after going through the setup wizard everything appears to be working. Upon reboot the issue starts.

I upgraded to version 2.6.1 firmware, factory reset, after going through the wizard, everything appears to be fine. I have not loaded any modules, reboot the Tetra, same issue occurs. I've factory reset multiple times, the issue always reappears after rebooting the Tetra. I've tried changing channels, going from 2.4 to 5 Ghz, lowering the txpower, nothing seems to help.

Link to comment
Share on other sites

  • 11 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...