Jump to content

TwinDucky FirmWare Not Working


Peak
 Share

Recommended Posts

Hi all, I've recently purchased a rubbyducky and so far looks promising. The main reason I purchased one was to use twinducky. Before you ask I have searched everywhere for a solution to my problem however none have worked. 

I have flashed the ducky using USB-Rubber Ducky and everything seems to work fine (when I unplug it makes a dismount sound and when I plug in it makes a mount sound on my PC. However I get no access to the drive (it does not show on my computer).

I did a little look around the forums and it looks like I should be using duck_v2.1.hex which isn't included on ducky-flasher. So I moved to updating the firmware manually. I download the hex from https://github.com/midnitesnake/USB-Rubber-Ducky/tree/master/Firmware/Images and copied the raw hex in to a text editor doc and saved and twinduck21.bin.

I then followed the manual DFU flash from https://github.com/hak5darren/USB-Rubber-Ducky/wiki/Flashing-ducky everything seems to be going fine until I get to:

./dfu-programmer at32uc3b1256 flash --suppress-bootloader-mem twinduck2.1.bin

I then get an error stating:

'Error parsing the line.
Something went wrong with creating the memory image.'

I even tried just using the stated tutorial recommendation:

./dfu-programmer at32uc3b1256 flash --suppress-bootloader-mem ducky-update.hex

This delivers the same message.

I can only re flash the clear rubbyducky using ducky-flasher.

If someone could please assist me with this and where I might be going wrong it would be much appreciated.

Please also note I'm running the newest version of Kali (debian).

Peak

Link to comment
Share on other sites

Thanks for your help illwill.

Bit of a weird one on this though. The ducky won't mount on my kali OS but when I switch over to windows and plug it in I can use it as a USB as well. Is this a possible bug in Kali or is this normal?

Anyway that's good enough for me so thank you.

Peak

Link to comment
Share on other sites

  • 5 months later...

I'm new to this

i'm having issues with my rubber ducky

i'm trying to use firmware : c_duck_v2_S001.hex - Triggered on CAPS/NUM/SCROLL LOCK

The Script of exfiltrate files is working when i do it manually - No issues with that

But when i plug in the duck i get green-red light and the payload doesnt start - only the mass storage opens in file explorer

Any idea what i'm doing wrong?

Pls Help 

Thanks in advance

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...