Jump to content

Ducky wont enter DFU mode!


mrkool101
 Share

Recommended Posts

Recently got my usb rubber ducky in the mail and it's been working great so far, except it doesn't seem to want to enter DFU mode. Unlike other people on the forum, the replay button works just fine, I've tested it multiple times. I've followed every tutorial I could find and none seem to work, I've tried it in every usb port on my machine, with and without the microsd, but even though i start holding the button down well before i plug it in, and keep it held for a while after, the ducky executes the current payload as though i wasn't, and doesn't show up in the device manager at all (win10 64x). I'm loving it so far with the base firmware but i feel like I'm missing out on a big part of the fun if i can't flash it, any help or ideas would be greatly appreciated.

Link to comment
Share on other sites

It could have something to do with the Atmel driver. I had a somewhat similar issue, but I can't say for certain the exact steps I took to fix it, but I know I messed around with it for a few good hours before getting it to work. Have you checked out this page? https://github.com/hak5darren/USB-Rubber-Ducky/wiki/Flashing-ducky Hopefully this gets you pointed in the right direction. If I weren't at work (don't tell my boss, hah) and had my home rig in front of me, I'd probably be more help. In the meantime, check out that link and see what you can come up with.

Best of luck!

Cheers,

-Enzym3

Link to comment
Share on other sites

Thanks Enzym3! Unfortunately I can't even get to the Atmel driver stage, the ducky wont enter dfu mode, and thus doesn't show up in device manager so i haven't been able to install the drivers, unless I'm missing something? Can / do the drivers need to be installed prior to inserting the ducky in dfu mode?

Link to comment
Share on other sites

On 11/23/2016 at 3:54 PM, mrkool101 said:

Recently got my usb rubber ducky in the mail and it's been working great so far, except it doesn't seem to want to enter DFU mode. Unlike other people on the forum, the replay button works just fine, I've tested it multiple times. I've followed every tutorial I could find and none seem to work, I've tried it in every usb port on my machine, with and without the microsd, but even though i start holding the button down well before i plug it in, and keep it held for a while after, the ducky executes the current payload as though i wasn't, and doesn't show up in the device manager at all (win10 64x). I'm loving it so far with the base firmware but i feel like I'm missing out on a big part of the fun if i can't flash it, any help or ideas would be greatly appreciated.

I have the same problem. Wish there was a solution!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...